
  





























<!DOCTYPE html>
        <html lang="en">
        <head>
<base href="https://www.dailyrecordnews.com/content/tncms/live/" />
<meta name="keywords" content="aidan, road bike, mountain bike, motor vehicle, transports, commerce, economics, bike, michael gallagher, photo" />
<meta name="news_keywords" content="aidan, road bike, mountain bike, motor vehicle, transports, commerce, economics, bike, michael gallagher, photo" />
<meta name="description" content="A while ago my eldest son Aidan, who is away at college, casually mentioned he might be interested in a road bike." />
<meta name="author" content="Michael Gallagher managing editor" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<meta name="apple-mobile-web-app-capable" content="yes" />
<meta name="apple-mobile-web-app-status-bar-style" content="black-translucent" />
<meta name="googlebot" content="noarchive" />
<meta name="google-site-verification" content="FxqRStJuutKePP9bF4JjzHE32RUZtiDi55RAHP6DdOE" />
<meta name="p:domain_verify" content="761a4f41b89213b6964944f38293afbc" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.dailyrecordnews.com/opinion/nation_of_mike/nation-of-mike-itll-work-out-fine-in-the-end/article_a9acb7ce-fe24-5a01-a44c-001a8d276fbc.html" />
<meta property="og:image" content="https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/e/ba/eba9d3b3-a3e2-548b-8709-222a26d2a9c0/5f2dad9aab1fa.image.jpg?resize=200%2C297" />
<meta property="og:image:width" content="200" />
<meta property="og:image:height" content="297" />
<meta property="og:title" content="Nation of Mike: It'll work out fine in the end" />
<meta property="og:description" content="A while ago my eldest son Aidan, who is away at college, casually mentioned he might be interested in a road bike." />
<meta property="og:site_name" content="Daily Record" />
<meta property="og:section" content="Nation Of Mike" />
<meta property="fb:app_id" content="2959550254137794" />
<meta property="article:publisher" content="https://www.facebook.com/ellensburgdailyrecord" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@EllensburgDR" />
<meta name="twitter:image:alt" content="Michael Gallagher" />
<meta property="tncms:subs" content="2.0" />
<link rel="stylesheet" href="https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/live/libraries/flex/components/png_core/resources/styles/png.css?_dc=1597129252"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/styles/bootstrap.min.44f4ed00052aeaf66307fd409db0d101.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/styles/layout.78b0163131a0eb95aef899d56f817c34.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/shared-content/art/tncms/templates/libraries/flex/components/themes/resources/styles/theme-basic.0740431ec2aa31f2e7d813ea5c660a8d.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/styles/flex-utility-promo-designer.59905c960650c756bd917d9e081675c9.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/styles/flex-utility-text-promo.945a2efac4892ce469180c513f411107.css"/>
<link rel="stylesheet" href="https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/live/libraries/flex/components/png_core/resources/styles/jquery.fancybox.css?_dc=1597129252"/>
<style>/*<![CDATA[*/ #user-controls-1266575 .user-controls .dropdown-menu > li > a { padding: 5px 20px; } #user-controls-1266575 .tn-user-screenname, #user-controls-1266575 .large-user-controls .user-welcome { padding: 0 5px; max-width: 75px; text-overflow: ellipsis; white-space: nowrap; overflow: hidden; } #user-controls-1266575 .large-user-controls .user-welcome { padding:0; max-width: 100%; font-weight: bold; } #user-controls-1266575 .dropdown-signup { font-size: 12px; } #user-controls-1266575 .large-user-controls .tn-user-screenname { padding: 0; } #user-controls-1266575 .large-user-avatar { margin-right: 10px; } #user-controls-1266575 .large-user-controls { font-size: 12px; } #user-controls-1266575 .logout-btn { cursor: pointer; } #user-controls-1266575 .user-welcome { color: #ffffff; } #user-controls-1266575 .login-btn { color: #fff!important; } #block-1266569 .search-spinner { position: absolute; } #block-1266569 .input-group-btn:last-child > .btn, .input-group-btn:last-child > .btn-group { margin-left: 0; } #site-search-1266569 { margin-bottom: 0; } #site-search-1266569 .site-search-form { padding: 0; } #site-search-1266569 #site-search-1266569-btn { outline: none; } #site-search-1266569 #site-search-1266569-term { border: 0; box-shadow: none; } #site-search-1266569 .site-search-form { box-shadow: none; } #user-controls-1266574 .user-controls .dropdown-menu > li > a { padding: 5px 20px; } #user-controls-1266574 .tn-user-screenname, #user-controls-1266574 .large-user-controls .user-welcome { padding: 0 5px; max-width: 75px; text-overflow: ellipsis; white-space: nowrap; overflow: hidden; } #user-controls-1266574 .large-user-controls .user-welcome { padding:0; max-width: 100%; font-weight: bold; } #user-controls-1266574 .dropdown-signup { font-size: 12px; } #user-controls-1266574 .large-user-controls .tn-user-screenname { padding: 0; } #user-controls-1266574 .large-user-avatar { margin-right: 10px; } #user-controls-1266574 .large-user-controls { font-size: 12px; } #user-controls-1266574 .logout-btn { cursor: pointer; } #user-controls-1266574 .login-btn { color: #fff!important; } #tncms-block-1266566 .tnt-prop-img { max-width: 300px; } #site-logo-1266566 { color: #666; } .follow-links-1266570 li { margin-right: 1px; padding: 0; } .follow-links-1266570 li a, .follow-links-1266570 li a:focus, .follow-links-1266570 li a:active { ; color: #ffffff!important; font-size: 18px; margin-right: 10px; opacity: .8; padding:0; box-shadow: none; } .follow-links-1266570 li a:hover { text-decoration: none; opacity: 1; } .follow-links-1266570 li a.fb:hover { color: #3A59A5; } .follow-links-1266570 li a.tw:hover { color: #46C8F9; } .follow-links-1266570 li a.yt:hover { color: #CE2B29; } .follow-links-1266570 li a.is:hover { color: #D4C4A2; } #tncms-block-1266567 .tnt-prop-img { max-width: 180px; } #site-logo-1266567 { color: #666; } #block-1266568 .search-spinner { position: absolute; } #block-1266568 .input-group-btn:last-child > .btn, .input-group-btn:last-child > .btn-group { margin-left: 0; } #site-search-1266568-dropdown .dropdown-menu { padding: 15px; width: 400px; font-weight: normal; } @media screen and (max-width: 991px) { #site-search-1266568-dropdown .dropdown-toggle { display: none; } #main-navigation .navbar-left { clear: both; } #site-search-1266568-dropdown .pull-right { float: none!important; } #site-search-1266568-dropdown .dropdown-menu { display: block; position: static; float: none; width: auto; margin-top: 0; background-color: transparent; border: 0; box-shadow: none; border-radius: 0; border-bottom: 1px solid rgba(0,0,0,0.1); } } #block-1830398 .card-panel { border: 5px solid; } #block-1830398 .panel { box-shadow: 10px 10px 10px -10px rgba(0,0,0,0.2); } #block-1830398 .card-panel { border-color: #ccc; } #block-1830398 .promo-designer { background-repeat: no-repeat; background-size: cover; } #block-1830398 .card-panel.panel { background-repeat: no-repeat; background-size: cover; background-position: center; }#block-1830398 .promo-designer, #block-1830398 .card-panel.panel { background-image: url(https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/custom/image/08a9d3d8-711c-11ea-b995-97a68d52545d.jpg) } #block-1830398.block { margin-bottom: 0 !important; } #block-1266564 .most-popular .tab-text { display: none; } #block-1266564 .most-popular .active .tab-text { display: inline; } /*]]>*/</style>
<script type="text/javascript">(function(){var tnsrc=window.location.hash.match(/[&#]tncms-source=([^&]+)/);var dl = window.dataLayer = window.dataLayer || [];dl.push({"tncms":{"template":{"version":"3.155.0"},"page":{"grid":"boxy","style":"default","path":"\/opinion\/nation_of_mike","syndicated":"false","reaction":"false","app":"editorial","theme":"flex","skin":"flex-editorial","http_status":200},"subscription":{"required":"true"},"asset":{"author":"Michael Gallagher\nmanaging editor","id":"a9acb7ce-fe24-5a01-a44c-001a8d276fbc","app":"editorial"},"vendor":{"outbrain":"disabled","taboola":""},"ad":{"vendor":"dfp premium"},"system":{"render_time":271},"client":{"is_bot":"no","is_gdpr":"no"}}});if (tnsrc && tnsrc[1]) {dl.push({'tncms.campaign.internal_source': tnsrc[1]});}window.addEventListener("DOMContentLoaded", function(oEvent) {var oTest = document.createElement('div');oTest.innerHTML = '&nbsp;';oTest.className = 'adsbox';document.body.appendChild(oTest);var nTimeoutID = window.setTimeout(function() {if (oTest.offsetHeight === 0) {dl.push({'event': 'tncms.ad.blocked'});}document.body.removeChild(oTest);window.clearTimeout(nTimeoutID);}, 100);});var nWidth=Math.max(document.documentElement.clientWidth, window.innerWidth || 0),aBPs=[[300,"Extra small: Most smartphones."],[768,"Small: Tablet devices."],[992,"Medium: Laptops & landscape tablets."],[1200,"Large: Desktop computers."]],i,c,aThisBP,aBP;for(i=0,c=aBPs.length;i<c;i++){aThisBP=aBPs[i];if(aBP===undefined||aThisBP[0]<=nWidth){aBP=aThisBP;}}if(aBP!==undefined){dl.push({'tncms.client.breakpoint':aBP[1]});}(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'tncms.start':new Date().getTime(),event:'tncms.start'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-PDQV3N');})();</script>
<script type="text/javascript">(function(){var tnsrc=window.location.hash.match(/[&#]tncms-source=([^&]+)/);var dl = window.dataLayer = window.dataLayer || [];dl.push({"tncms":{"template":{"version":"3.155.0"},"page":{"grid":"boxy","style":"default","path":"\/opinion\/nation_of_mike","syndicated":"false","reaction":"false","app":"editorial","theme":"flex","skin":"flex-editorial","http_status":200},"subscription":{"required":"true"},"asset":{"author":"Michael Gallagher\nmanaging editor","id":"a9acb7ce-fe24-5a01-a44c-001a8d276fbc","app":"editorial"},"vendor":{"outbrain":"disabled","taboola":""},"ad":{"vendor":"dfp premium"},"system":{"render_time":271},"client":{"is_bot":"no","is_gdpr":"no"}}});if (tnsrc && tnsrc[1]) {dl.push({'tncms.campaign.internal_source': tnsrc[1]});}window.addEventListener("DOMContentLoaded", function(oEvent) {var oTest = document.createElement('div');oTest.innerHTML = '&nbsp;';oTest.className = 'adsbox';document.body.appendChild(oTest);var nTimeoutID = window.setTimeout(function() {if (oTest.offsetHeight === 0) {dl.push({'event': 'tncms.ad.blocked'});}document.body.removeChild(oTest);window.clearTimeout(nTimeoutID);}, 100);});var nWidth=Math.max(document.documentElement.clientWidth, window.innerWidth || 0),aBPs=[[300,"Extra small: Most smartphones."],[768,"Small: Tablet devices."],[992,"Medium: Laptops & landscape tablets."],[1200,"Large: Desktop computers."]],i,c,aThisBP,aBP;for(i=0,c=aBPs.length;i<c;i++){aThisBP=aBPs[i];if(aBP===undefined||aThisBP[0]<=nWidth){aBP=aThisBP;}}if(aBP!==undefined){dl.push({'tncms.client.breakpoint':aBP[1]});}(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-TN5DF3N');})();</script>
<script src="https://tags.crwdcntrl.net/c/9940/cc.js?ns=_cc9940" id="LOTCC_9940"></script>
<script>
	if(document.cookie.indexOf('tncms-dmp-id') != -1) {
		_cc9940.add('tp', 'TNNW');
		_cc9940.add('act', ' User Login');
		_cc9940.add('tpid', document.cookie.split( ';' ).map( function( x ) { return x.trim().split( '=' ); } ).reduce(function( a, b ) { a[ b[ 0 ] ] = b[ 1 ]; return a; }, {} )[ "tncms-dmp-id"]);
		document.cookie = 'tncms-dmp-id=;expires=Thu, 01 Jan 1970 00:00:01 GMT';
		sessionStorage.removeItem('tncms.behaviors');
		sessionStorage.removeItem('tncms.dmp.audiences');
	}
	_cc9940.bcp();
</script>

<script src="/shared-content/art/tncms/user/user.js"></script>
<script src="/shared-content/art/tncms/tracking.js"></script>
<script src="/shared-content/art/tncms/subscription.js"></script>
<script>/*<![CDATA[*/ TNCMS.Subscription.initialize({"service_id": "7462", "prefix": ""}); /*]]>*/</script>
<script src="//s.ntv.io/serve/load.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/shared-content/art/tncms/templates/libraries/flex/components/jquery/resources/scripts/jquery.min.6edb5af3e93b0a377ec925c5f1c6ddde.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/scripts/bootstrap.min.d457560d3dfbf1d56a225eb99d7b0702.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/common.5ee3960b4d37bc106988fa535b393865.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.1477faac295a3745e4796d2263e75f11.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/application.93d1db0a57d520951552a1dcd8fd9aeb.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.navigation.accessibility.3184e9304073379bbe4e2c6500858bb1.js"></script>
<script src="https://polyfill.io/v3/polyfill.min.js?features=default,fetch,IntersectionObserver,NodeList.prototype.@@iterator,Element.prototype.classList|gated" nomodule="nomodule"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/shared-content/art/tncms/templates/libraries/flex/components/subscription/resources/scripts/tnt.access.status.828de94349981272665c0fb0107f3e49.js"></script>
<script>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</script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/scripts/user-controls.578df3df79d812af55ab13bae47f9857.js"></script>
<script>/*<![CDATA[*/ var __tnt = __tnt || {};
    __tnt.ads = __tnt.ads || {};
    __tnt.ads.dfp = __tnt.ads.dfp || {};
    __tnt.ads.dfp.slots = __tnt.ads.dfp.slots || {};
    __tnt.ads.dfp.targeting = __tnt.ads.dfp.targeting || {};
    __tnt.ads.dfp.targeting.k = ["aidan","road bike","mountain bike","motor vehicle","transports","commerce","economics","bike","michael gallagher","photo"];
    __tnt.ads.dfp.refresh = true;
    
    __tnt.ads.dfp.targeting.page=["asset","article","app-editorial"];
    if( typeof window.I10C != 'undefined' && typeof window.I10C.Morph != 'undefined' ){
        __tnt.ads.dfp.targeting.page.push('recover');
    }
    
    __tnt.docWidth = window.innerWidth;
    if( __tnt.docWidth > 1899 ){ 
        __tnt.docWidthBreakPoint = 'xl_screen';
    } else if ( __tnt.docWidth > 1619 ){
        __tnt.docWidthBreakPoint = 'lg_screen';
    } else if ( __tnt.docWidth > 991 ){
        __tnt.docWidthBreakPoint = 'md_screen';
    } else if ( __tnt.docWidth > 767 ){
        __tnt.docWidthBreakPoint = 'sm_screen';
    } else {
        __tnt.docWidthBreakPoint = 'xs_screen';
    }
    __tnt.ads.dfp.targeting.page.push(__tnt.docWidthBreakPoint);

    __tnt.ads.dfp.targeting.browser = __tnt.client.browser.name;
    
    window.googletag = window.googletag || {};
    window.googletag.cmd = window.googletag.cmd || [];

    (function() {
        var gads = document.createElement('script');
        gads.async = true;
        gads.type = 'text/javascript';
        var useSSL = 'https:' == document.location.protocol;
        gads.src = (useSSL ? 'https:' : 'http:') + '//securepubads.g.doubleclick.net/tag/js/gpt.js';
        var node = document.getElementsByTagName('script')[0];
        node.parentNode.insertBefore(gads, node);
    })(); /*]]>*/</script>
<script>/*<![CDATA[*/ window.APS_dfp_ads = [];
    
    !function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");
    
    apstag.init({
        pubID: '3266',
        adServer: 'googletag',
        params: {
            sections: 'opinion'
        }
    }); /*]]>*/</script>
<script>/*<![CDATA[*/ window.promo_design_config || (window.promo_design_config = []); window.promo_design_config.push({"button_size":"btn-lg","button_style":"danger","button_text":"Contribute","button_url":"\/contribute","card_shape":"rounded_rectangle","content_text":"Now, more than ever, the world needs trustworthy reporting\u2014but good journalism isn\u2019t free. Please support us by making a contribution.","content_text_color":"light","content_text_shadow":"enabled","display_again":"24","display_timer":"1","display_triggers":"visitor_enter","headline_shadow":"enabled","headline_size":"large","headline_text":"Support local journalism","headline_text_color":"light","image":{},"image_display":"background","overlay_action":"centered","utm_campaign_name":"contribute","heading_tag":"h3","heading_bg_color":"","heading_text_color":"inherit","note":"","links_position":"top","display_width":"region","card_shadow":"enabled","bg_color":"","outline_color":"#ccc","border_width":"5","sticker_shape":"disabled","sticker_color":"#333333","sticker_icon":"exclamation","sticker_icon_color":"white","lead_in":"","lead_text_color":"dark","lead_text_shadow":"disabled","info_text":"","info_text_color":"dark","info_text_shadow":"disabled","enable_email":"","require_user_account":"","signup_lists_only":"","list_ids":"","email_text_color":"dark","email_text_shadow":"disabled","email_button_style":"default","sign_up_text":"Sign up","manage_button_text":"Manage your lists","utm_tracking":"0","utm_source":"blox","utm_medium":"utility_promo_designer","utm_campaign":"pop_up","utm_campaign_content":"utility_promo_designer","show_audience":"","hide_audience":"","block_id":"1830398"}); /*]]>*/</script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/sms-link.8eefede3265fd6c6de07bc0cb5f3f779.js"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/shared-content/art/tncms/templates/libraries/flex/components/asset/resources/scripts/tnt.nextPrev.f1660ccf5d097410b8b72737d216878c.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/tnt.ads.adverts.66a3812a7b5c12fde8cd998fd691ad7d.js"></script>
<script>/*<![CDATA[*/ __tnt.recentFive = {
    /*
     * Gets the data stored in 'tnt:recent:five'
     * Returns Array
     */
        get:function(){
            if(window.localStorage && localStorage.getItem('tnt:recent:five')!=null){
                try{ return JSON.parse(localStorage.getItem('tnt:recent:five')); } catch {}
            }

            return [];
        },

    /*
     * Sets the 'tnt:recent:five' localStorage item
     * Returns boolean
     */
        set:function(data){
            if(window.localStorage){
                try{ 
                    localStorage.setItem('tnt:recent:five', JSON.stringify(data));
                    return true;
                } catch {}
            }

            return false;
        },

    /*
     * Adds the most recent item, prunes any duplicates, and trims the array down to 5 items
     * Returns Array on success, false on fail 
     */
        add:function(asset){
            var assets = __tnt.recentFive.get();
            assets.unshift(asset);

            if(assets.length > 1){
                assets = assets.filter(function(item, index, a){ return a.indexOf(item) == index });

                while(assets.length>5){
                    assets.shift();
                }
            }

            if(__tnt.recentFive.set(assets)){ return assets; }
            return false;
        }
    }; /*]]>*/</script>

            
            <title>Nation of Mike: It'll work out fine in the end | Nation Of Mike | dailyrecordnews.com</title>
            
    <style>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</style> <style> </style>
    
        <link rel="shortcut icon" type="image/x-icon" href="https://www.dailyrecordnews.com/content/tncms/site/icon.ico" />
    
        <link rel="apple-touch-icon" href="https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/custom/image/9d655612-d7c3-11e8-9190-bbbc9e2de7d1.png?resize=180%2C180" />
    
        <link rel="amphtml" href="https://www.dailyrecordnews.com/opinion/nation_of_mike/nation-of-mike-itll-work-out-fine-in-the-end/article_a9acb7ce-fe24-5a01-a44c-001a8d276fbc.amp.html" />
    
        <link rel="preconnect" href="//www.google.com">
    
        <link rel="preconnect" href="//adservice.google.com">
    
        <link rel="preconnect" href="//securepubads.g.doubleclick.net">
    
        <link rel="preconnect" href="//stats.g.doubleclick.net">
    
        <link rel="preconnect" href="//tpc.googlesyndication.com">
    
        <link rel="preconnect" href="//pagead2.googlesyndication.com">
    
        <link rel="preconnect" href="//www.googletagmanager.com">
    
        <link rel="preconnect" href="//www.google-analytics.com">
    
        <link rel="preconnect" href="//connect.facebook.net">
    
        <link rel="preconnect" href="//bcp.crwdcntrl.net">
    
        <link rel="preconnect" href="//tags.crwdcntrl.net">
    <link rel="alternate" type="application/rss+xml" title="Nation of Mike: It'll work out fine in the end | Nation Of Mike | dailyrecordnews.com" href="http://www.dailyrecordnews.com/search/?f=rss&amp;t=article&amp;c=opinion/nation_of_mike&amp;l=50&amp;s=start_time&amp;sd=desc" />
    <link rel="canonical" href="https://www.dailyrecordnews.com/opinion/nation_of_mike/nation-of-mike-itll-work-out-fine-in-the-end/article_a9acb7ce-fe24-5a01-a44c-001a8d276fbc.html" />
            <script defer src="https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/fontawesome.edd147e4c2830f416874012247117438.js"></script>
            
        </head>
        <body class="fixed-scroll-nav app-editorial grid-boxy blox-asset uuid-a9acb7ce-fe24-5a01-a44c-001a8d276fbc  section-opinion section-nation-of-mike type-article infinity-disabled" data-path="/opinion/nation_of_mike">
	<script type='text/javascript' src='/shared-content/art/stats/common/tracker.js'></script>
	<script type='text/javascript'>
	<!--
	if (typeof(TNStats_Tracker) !== 'undefined' && typeof(TNTracker) === 'undefined') { TNTracker = new TNStats_Tracker('www.dailyrecordnews.com'); TNTracker.trackPageView(); }
	// -->
	</script>
	<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PDQV3N&amp;tncms.template.version=3.155.0&amp;tncms.page.grid=boxy&amp;tncms.page.style=default&amp;tncms.page.path=%2Fopinion%2Fnation_of_mike&amp;tncms.page.syndicated=false&amp;tncms.page.reaction=false&amp;tncms.page.app=editorial&amp;tncms.page.theme=flex&amp;tncms.page.skin=flex-editorial&amp;tncms.page.http_status=200&amp;tncms.subscription.required=true&amp;tncms.asset.author=Michael+Gallagher%0Amanaging+editor&amp;tncms.asset.id=a9acb7ce-fe24-5a01-a44c-001a8d276fbc&amp;tncms.asset.app=editorial&amp;tncms.vendor.outbrain=disabled&amp;tncms.vendor.taboola=&amp;tncms.ad.vendor=dfp+premium&amp;tncms.system.render_time=271&amp;tncms.client.is_bot=no&amp;tncms.client.is_gdpr=no&amp;tncms.client.noscript=yes" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-TN5DF3N&amp;tncms.template.version=3.155.0&amp;tncms.page.grid=boxy&amp;tncms.page.style=default&amp;tncms.page.path=%2Fopinion%2Fnation_of_mike&amp;tncms.page.syndicated=false&amp;tncms.page.reaction=false&amp;tncms.page.app=editorial&amp;tncms.page.theme=flex&amp;tncms.page.skin=flex-editorial&amp;tncms.page.http_status=200&amp;tncms.subscription.required=true&amp;tncms.asset.author=Michael+Gallagher%0Amanaging+editor&amp;tncms.asset.id=a9acb7ce-fe24-5a01-a44c-001a8d276fbc&amp;tncms.asset.app=editorial&amp;tncms.vendor.outbrain=disabled&amp;tncms.vendor.taboola=&amp;tncms.ad.vendor=dfp+premium&amp;tncms.system.render_time=271&amp;tncms.client.is_bot=no&amp;tncms.client.is_gdpr=no&amp;tncms.client.noscript=yes" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
    <div class='hidden-xs'>
        
    </div><div id="fb-root"></div>
        
        
        
        
        <script>
            document.addEventListener("DOMContentLoaded", function(event) {
                __tnt.metering.access.d.push(function(){
                    //DMP logging
                    if(window._cc){
                        __tnt.log("Logging DMP data")
                        var paywallDmpData = 'Paywall : Viewed Paywall';
                        // Call to cms.dmp.js_behavior_action is here
                        _cc9940.add('act', paywallDmpData );_cc9940.bcp();
                    }
                });
            });
        </script>
    

    <div id="template-metering" data-message-mode="login">
    <template class="template meter subscription">
        <div class="meter message" data-message="newzware subscription wall">
        <div class="wall panel panel-default">
            <div class="panel-body">
                <h4 class="meter-heading media-heading">
                    Thank you for reading!
                </h4>
                <p>Please <span class="not-logged-in">log in, or sign up for a new account and</span> purchase a subscription to continue reading.</p>

                <div class="not-logged-in col-xs-12">
                    <div class="col-xs-6">
                        
    <a  class="btn btn-default btn-block" href="/tncms/auth/begin/?provider=Newzware&return=https%3A%2F%2Fwww.dailyrecordnews.com%2Fopinion%2Fnation_of_mike%2Fnation-of-mike-itll-work-out-fine-in-the-end%2Farticle_a9acb7ce-fe24-5a01-a44c-001a8d276fbc.html">Sign Up</a>
                    </div>
                    <div class="col-xs-6">
                        
    <a class="btn btn-primary btn-block" href="https://www.dailyrecordnews.com/users/login/?referer_url=https%3A%2F%2Fwww.dailyrecordnews.com%2Fopinion%2Fnation_of_mike%2Fnation-of-mike-itll-work-out-fine-in-the-end%2Farticle_a9acb7ce-fe24-5a01-a44c-001a8d276fbc.html">Log In</a>
                    </div>
                </div>
                <div class="logged-in col-xs-12">
                    <div class="pull-right">
                    <a class="btn btn-default btn-block meter-modal-open">Purchase a Subscription</a>
                    </div>
                </div>
            </div>
        </div>
        </div>
    
    
</template>
    
    <template class="template meter registration">
        
    <div class="meter message wall panel panel-default" data-message="blox registration wall">
        <div class="panel-body">
            <h4 class="meter-heading media-heading">
                Thank you for reading!

            </h4>
            <p>Please <span class="not-logged-in">log in, or sign up for a new account</span> to continue reading.</p>

            <div class="col-xs-12">
                <div class="row not-logged-in">
                
                    <div class="col-xs-6">
                        
    <a  class="btn btn-default btn-block" href="/tncms/auth/begin/?provider=Newzware&return=https%3A%2F%2Fwww.dailyrecordnews.com%2Fopinion%2Fnation_of_mike%2Fnation-of-mike-itll-work-out-fine-in-the-end%2Farticle_a9acb7ce-fe24-5a01-a44c-001a8d276fbc.html">Sign Up</a>
                    </div>
                    <div class="col-xs-6">
                        
    <a class="btn btn-primary btn-block" href="https://www.dailyrecordnews.com/users/login/?referer_url=https%3A%2F%2Fwww.dailyrecordnews.com%2Fopinion%2Fnation_of_mike%2Fnation-of-mike-itll-work-out-fine-in-the-end%2Farticle_a9acb7ce-fe24-5a01-a44c-001a8d276fbc.html">Log In</a>
                    </div>
                </div>
                
                <div class="row logged-in">
                    <a class="btn btn-default" href="https://www.dailyrecordnews.com/users/admin/service/purchase/?referer_url=https%253A%252F%252Fwww.dailyrecordnews.com%252Fopinion%252Fnation_of_mike%252Fnation-of-mike-itll-work-out-fine-in-the-end%252Farticle_a9acb7ce-fe24-5a01-a44c-001a8d276fbc.html">Purchase a Subscription
</a>
                </div>
            </div>
        </div>
    </div>
</template>
    
    <template class="template meter referred">
        <div class="meter notification referred alert alert-dismissable alert-info" data-message="blox user referred">
        <button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button>
         
        <p><strong>Thank you for reading!
</strong> We hope that you continue to enjoy our free content.</p>
    </div>
</template>
    
    
<div id="subscription-modal" class="subscription metering-modal modal fade" data-message="newzware modal subscription" >
    <div class="modal-dialog">
        <div class="modal-content">
            <div class="modal-header">
                <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
                <h4 class="modal-title">Thank you for reading.</h4>
            </div>
            
            <div class="modal-body">    
                <div class="row">
                    <div class="col-xs-12">
                        <div class="not-logged-in">
                        
                            <p>Please log in, or sign up for a new account and purchase a subscription to continue reading.</p>
                        
                        </div>

                        <div class="logged-in">
                            <div class="no-services" style="display:none">
                                <p>Please purchase a subscription to continue reading.</p>
                            </div>
                
                            <div class="has-services" style="display:none">
                                <p>Your current subscription does not provide access to this content.</p>
                            </div>
                        </div>

                        <div class="col-xs-12">
                            <div class="row not-logged-in padding-bottom">
                                <div class="col-xs-6">
                                    
    <a  class="btn btn-default btn-block" href="/tncms/auth/begin/?provider=Newzware&return=https%3A%2F%2Fwww.dailyrecordnews.com%2Fopinion%2Fnation_of_mike%2Fnation-of-mike-itll-work-out-fine-in-the-end%2Farticle_a9acb7ce-fe24-5a01-a44c-001a8d276fbc.html">Sign Up</a>
                                </div>
                                <div class="col-xs-6">
                                    
    <a class="btn btn-primary btn-block" href="https://www.dailyrecordnews.com/users/login/?referer_url=https%3A%2F%2Fwww.dailyrecordnews.com%2Fopinion%2Fnation_of_mike%2Fnation-of-mike-itll-work-out-fine-in-the-end%2Farticle_a9acb7ce-fe24-5a01-a44c-001a8d276fbc.html">Log In</a>
                                </div>
                            </div>
                
                            <div class="row logged-in">
                                <div class="pull-right">
                                    <a class="btn btn-default" href="https://www.dailyrecordnews.com/users/admin/service/purchase/">Purchase a Subscription</a>
                                </div>
                            </div>
                            </div>
                        
                        
                    </div>
                </div>            
            </div>
            <div class="modal-footer" style="display:none;">
            </div>
        </div>
    </div>
</div>

<script>
    $(function(){
        var i = 0;
        $('#subscription-modal').find('.subscription-services').find('.subscription-service').each(function(){
            $(this).attr('id','service-tab-'+i);
        
            $(this).find('.panel-heading h3').html('<a href="" data-toggle="collapse" data-parent="services-modal-collapsable-tabs" aria-expanded="false" aria-controls="service-tab-'+i+'">'+$(this).find('.panel-heading h3').text()+'</a>')
            $(this).find('.panel-body').addClass('panel-collapse collapse').attr('role','tabpanel');
            
            if(i==0){
                $(this).find('.panel-collapse').collapse('show');
                $(this).find('.panel-footer').show();
            }else{
                $(this).find('.panel-footer').hide();
            }
        
            i++;
        });
    
        $('.subscription-services-filter').hide();
        $('#subscription-modal').find('.subscription-services .subscription-service .service-heading').css({'padding':'0px'});
        $('#subscription-modal').find('.subscription-services .subscription-service .service-heading').find('a').css({'display':'block','padding':'10px 15px'});
        $('#subscription-modal').find('.subscription-services .subscription-service .service-heading').find('a[data-toggle=collapse]').on('click',function(event){
            var id = $(this).attr('aria-controls');
            var open = $('#'+id).find('.collapse').hasClass('in');
            
            $('#subscription-modal').find('.subscription-services .subscription-service').each(function(){
                if(this.id == id){
                    $(this).find('.panel-collapse').collapse('show');
                    $(this).find('.panel-footer').show();
                }else{
                    $(this).find('.panel-collapse').collapse('hide');
                    $(this).find('.panel-footer').hide();
                }
            });
        });
        
        $('#asset-content').find('.subscription-required').find('.panel-footer').find('a[data-toggle=collapse]').on('click',function(event){
            $(this).parents('.panel-footer').find('.collapse.collapse-rates').collapse('toggle');
        });
        
        
        $('#asset-content').find('.meter-modal-open').on('click',function(){
            $('#asset-content').find('.alert.notification').css({'z-index':'900'});
            $("#template-metering").find('.metering-modal').first().modal();
        
        });
        
    });
    
</script>

    
</div>
<script>
            $(function(){
                var bloxServiceIDs = [];
                var bloxUserServiceIds = [];
                var dataLayer = window.dataLayer || [];

                
                bloxServiceIDs.push(7462);
                

                if (__tnt.user.services){
                    var bloxUserServiceIDs = __tnt.user.services.replace('%2C',',').split(',');
                }

                // GTM tncms.subscription.paid_access_service_ids
                if(bloxServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'access_service_ids':bloxServiceIDs.toString()}}});
                }

                // GTM tncms.subscrption.user_service_ids
                if(bloxUserServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'user_service_ids':bloxUserServiceIDs.toString()}}});
                }
            });
        </script>
        
        <div id="site-container"><div id="asset-admin-bar" class="asset-edit-bar hidden-print">
                <div class="asset-edit-icon"><i class="fas tnt-lock-open tnt-fw"></i></div>
                <div class="asset-edit-message">You have permission to edit this article.</div>
                <div class="asset-edit-btns">
                    <a class="btn btn-primary btn-sm" target="_blank" rel="noopener" href="https://www.dailyrecordnews.com/tncms/admin/editorial-asset/?edit=a9acb7ce-fe24-5a01-a44c-001a8d276fbc"><i class="fas tnt-pencil-alt tnt-fw"></i> Edit</a>
                    <button class="asset-edit-close btn btn-link btn-sm"><i class="fas tnt-times"></i><span class="sr-only">Close</span></button>
                </div>
            </div>
        
    
    

    
        
        
           <aside class="hidden-print offcanvas-drawer offcanvas-drawer-right visible-sm visible-xs">
                <div id="tncms-region-mobile-nav-top-right-region" class="tncms-region "><div id="tncms-block-1266575" class="tncms-block"><div id="user-controls-1266575" class="user-controls show-onload clearfix pull-right"><div class="not-logged-in">
        <ul class="list-inline"><li><a href="/tncms/auth/begin/?provider=Newzware&return=https%3A%2F%2Fwww.dailyrecordnews.com%2Fopinion%2Fnation_of_mike%2Fnation-of-mike-itll-work-out-fine-in-the-end%2Farticle_a9acb7ce-fe24-5a01-a44c-001a8d276fbc.html" class="btn btn-link btn-sm user-control-link" rel="nofollow">Sign Up</a></li><li><a href="https://www.dailyrecordnews.com/users/login/?referer_url=https%3A%2F%2Fwww.dailyrecordnews.com%2Fopinion%2Fnation_of_mike%2Fnation-of-mike-itll-work-out-fine-in-the-end%2Farticle_a9acb7ce-fe24-5a01-a44c-001a8d276fbc.html" class="btn btn-primary btn-sm login-btn user-control-link" rel="nofollow">Log In</a></li>
        </ul>
    </div>

    <div class="logged-in">
        
        
            <div class="hide show-offcanvas">
                <ul class="list-inline">
                    <li><a href="https://www.dailyrecordnews.com/users/admin/" class="btn btn-primary btn-sm login-btn user-control-link">Dashboard</a></li>
                    <li> <a class="btn btn-link btn-sm user-control-link" onclick="document.getElementById('user-logout-form-1266575').submit(); return false;" rel="nofollow"> Logout</a></li>
                </ul>
            </div>
        
        <ul class="hide-offcanvas list-inline"><li class="dropdown pull-right">
                
                <div class="dropdown-toggle btn btn-link btn-sm user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><div class="tn-user-avatar pull-left"><!-- user avatar --></div><span class="tn-user-screenname pull-left"></span><b class="caret user-control-link"></b>
                </div>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li role="menuitem"><a href="https://www.dailyrecordnews.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li role="menuitem"><a class="tn-user-profile-url" href="" data-app="https://www.dailyrecordnews.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li role="menuitem"><a href="https://www.dailyrecordnews.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem"><a class="logout-btn" onclick="document.getElementById('user-logout-form-1266575').submit(); return false;" rel="nofollow"><i class="fas tnt-power-off tnt-fw"></i> Logout</a></li>
                </ul>
            </li>
            
        </ul>
    </div>
</div>

<form method="post" action="https://www.dailyrecordnews.com/users/logout/" id="user-logout-form-1266575"><input type="hidden" name="referer_url" value="https://www.dailyrecordnews.com/opinion/nation_of_mike/nation-of-mike-itll-work-out-fine-in-the-end/article_a9acb7ce-fe24-5a01-a44c-001a8d276fbc.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div><div id="tncms-block-1266569" class="tncms-block"><section id="block-1266569" class="block emphasis-h3   " >
    <div class="clearfix"></div>
    <div id="search-form-1266569" class="search-form-container card clearfix text-center hidden-print ">
    <form id="site-search-1266569" aria-labelledby="site-search-button-1266569" action="/search/" method="GET" >
    <input type="hidden" name="l" value="25">
    
        
        <input type="hidden" name="sort" value="relevance">
    
    
    
    
    <input type="hidden" name="f" value="html">
    
        
        <input type="hidden" name="t" value="article,video,youtube,collection">
    
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div class="site-search-form input-group default input-group-sm form-control">
        <input id="site-search-1266569-term" name="q" title="Site Search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-1266569-btn" class="btn btn-link" aria-label="Submit Site Search" type="submit">
                
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form>
        
        
        <div class="clearfix"></div>
    </div>
    </section> 

<script>
    $('#site-search-1266569-btn').on(__tnt.client.clickEvent, function(){
        $('#site-search-1266569').submit();
        return false;
    });

    $('#site-search-1266569').on('submit', function(){
        // Filter query
        var sQueryFiltered = $("#site-search-1266569 input[name=q]").val().replace(/\?/g, '');
    $("#site-search-1266569 input[name=q]").val( sQueryFiltered );

        if( $('#site-search-1266569-term').val() ){
            return true;
        }else{
            return false;
        }
    });</script>
</div></div>
                <div id="tncms-region-nav-mobile-nav-right" class="tncms-region-nav"><div id="mobile-nav-right_menu" class="panel-group nav navbar-nav" role="tablist" aria-hidden="true"><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-1" data-target="#mobile-nav-right_menu-child-1">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a tabindex="-1" aria-hidden="true" href="/"  class="nav-link tnt-section-home">Home</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-1" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/site/contact"  class="nav-link tnt-section-contact-us">Contact Us</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="http://local.dailyrecordnews.com/"  target="_blank" rel="noopener" class="nav-link tnt-section-ownlocal-businesses">OwnLocal Businesses</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/subscribe/"  class="nav-link tnt-section-subscribe-today">Subscribe today!</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="https://issuu.com/dailyrecord/docs/rate_card_daily_record_2020"  target="_blank" rel="noopener" class="nav-link tnt-section-2020-rate-card">2020 Rate Card</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-2" data-target="#mobile-nav-right_menu-child-2">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a tabindex="-1" aria-hidden="true" href="/news"  class="nav-link tnt-section-news">News</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-2" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/wildfire/"  class="nav-link tnt-section-wa-wildfires">WA Wildfires</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news"  class="nav-link tnt-section-local-news">Local News</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/uppercounty/"  class="nav-link tnt-section-uppercounty">Uppercounty</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/inbrief/"  class="nav-link tnt-section-in-brief">In Brief</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/election"  class="nav-link tnt-section-election-2020">Election 2020</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/blotter/"  class="nav-link tnt-section-police-blotter">Police Blotter</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/state/"  class="nav-link tnt-section-state-news">State News</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/national/"  class="nav-link tnt-section-national-news">National News</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/weather"  class="nav-link tnt-section-weather">Weather</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/garden-of-the-month-form/pdf_f7ee68fa-a6bc-11e2-89b2-001a4bcf887a.html"  class="nav-link tnt-section-garden-of-the-month-form">Garden of the Month Form</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="//kvnews.mycapture.com/mycapture/index.asp?"  class="nav-link tnt-section-buy-news-photos">Buy News Photos</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/gallery"  class="nav-link tnt-section-photos">Photos</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/videos"  class="nav-link tnt-section-videos">Videos</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/search"  class="nav-link tnt-section-search">Search</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/site/forms/submit/news/"  class="nav-link tnt-section-submit-news">Submit News</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="http://goo.gl/FrqUp"  target="_blank" rel="noopener" class="nav-link tnt-section-archives-1880-2004">Archives:  1880-2004</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/gallery"  class="nav-link tnt-section-i-classfa-fa-photoi-photo-galleries"><i class='fa fa-photo'></i> Photo Galleries</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/coronavirus/"  class="nav-link tnt-section-covid-19">COVID-19</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-4" data-target="#mobile-nav-right_menu-child-4">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a tabindex="-1" aria-hidden="true"   class="nav-link tnt-section-newsletters">Newsletters</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-4" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/newsletter/monday/"  class="nav-link tnt-section-monday">Monday</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-5" data-target="#mobile-nav-right_menu-child-5">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a tabindex="-1" aria-hidden="true" href="/rodeo/"  class="nav-link tnt-section-rodeo">Rodeo</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-5" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/rodeo/"  class="nav-link tnt-section-rodeo-news">Rodeo News</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/rodeo/schedule/"  class="nav-link tnt-section-schedule">Schedule</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-6" data-target="#mobile-nav-right_menu-child-6">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a tabindex="-1" aria-hidden="true" href="/sports"  class="nav-link tnt-section-sports">Sports</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-6" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/sports"  class="nav-link tnt-section-sports">Sports</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/sports/cwu_wildcats/"  class="nav-link tnt-section-cwu-wildcats">CWU Wildcats</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/rodeo/"  class="nav-link tnt-section-rodeo">Rodeo</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/site/forms/submit/sports/"  class="nav-link tnt-section-submit-sports-news">Submit Sports News</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="//kvnews.mycapture.com/mycapture/index.asp?"  class="nav-link tnt-section-buy-sports-photo">Buy Sports Photo</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/sports/ap_auto/"  class="nav-link tnt-section-ap-auto-racing">AP Auto Racing</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/sports/ap_cbasketball/"  class="nav-link tnt-section-ap-college-basketball">AP College Basketball</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/sports/ap_cfootball/"  class="nav-link tnt-section-ap-college-football">AP College Football</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/sports/seahawks/"  class="nav-link tnt-section-seattle-seahawks-ap">Seattle Seahawks [AP]</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/sports/mariners/"  class="nav-link tnt-section-seattle-mariners-ap">Seattle Mariners [AP]</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/sports/sounders/"  class="nav-link tnt-section-seattle-sounders-ap">Seattle Sounders [AP]</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/sports/storm/"  class="nav-link tnt-section-seattle-storm-ap">Seattle Storm [AP]</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-7" data-target="#mobile-nav-right_menu-child-7">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a tabindex="-1" aria-hidden="true"   class="nav-link tnt-section-features">Features</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-7" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/business"  class="nav-link tnt-section-business">Business</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/religion/"  class="nav-link tnt-section-religion">Religion</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/outdoors/"  class="nav-link tnt-section-outdoors">Outdoors</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/familyandeducation/"  class="nav-link tnt-section-family-education">Family & Education</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/weekendlife/"  class="nav-link tnt-section-weekend-life">Weekend Life</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/scrapbook/"  class="nav-link tnt-section-scrapbook">Scrapbook</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="http://www.parade.com"  target="_blank" rel="noopener" class="nav-link tnt-section-parade-magazine">Parade Magazine</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/site/forms/online_services/submit_business_news/"  class="nav-link tnt-section-submit-business-news">Submit Business News</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="http://local.dailyrecordnews.com/"  target="_blank" rel="noopener" class="nav-link tnt-section-ownlocal-market-place">OwnLocal Market Place</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="http://kittitascountyrealestate.com/"  target="_blank" rel="noopener" class="nav-link tnt-section-kittitas-county-real-estate">Kittitas County Real Estate</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-8" data-target="#mobile-nav-right_menu-child-8">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a tabindex="-1" aria-hidden="true" href="/opinion"  class="nav-link tnt-section-opinion">Opinion</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-8" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/opinion/editorial/"  class="nav-link tnt-section-editorial">Editorial</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/opinion/letters_to_the_editor/"  class="nav-link tnt-section-letters-to-the-editor">Letters to the Editor</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/opinion/guest_columns/"  class="nav-link tnt-section-guest-columns">Guest Columns</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/opinion/nation_of_mike/"  class="nav-link tnt-section-nation-of-mike">Nation of Mike</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/site/forms/submit/letters/"  class="nav-link tnt-section-submit-a-letter-to-the-editor">Submit a letter to the editor</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/site/forms/submit/thumbs/"  class="nav-link tnt-section-submit-thumbs-up-down">Submit Thumbs Up Down</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-9" data-target="#mobile-nav-right_menu-child-9">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a tabindex="-1" aria-hidden="true" href="/calendar"  class="nav-link tnt-section-calendar">Calendar</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-9" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="https://portal.cityspark.com/EventEntry/EventEntry/EllensburgDailyRecord"  target="_blank" rel="noopener" class="nav-link tnt-section-submit-calendar-item">Submit Calendar Item</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/calendar"  class="nav-link tnt-section-community-events">Community Events</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-10" data-target="#mobile-nav-right_menu-child-10">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a tabindex="-1" aria-hidden="true"   class="nav-link tnt-section-obituaries">Obituaries</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-10" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="//selfserve.dailyrecordnews.com/dailyrecord-adportal/obits/index.html"  class="nav-link tnt-section-submit-an-obituary">Submit an obituary</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="https://www.legacy.com/obituaries/kvnews/"  target="_blank" rel="noopener" class="nav-link tnt-section-read-todays-obituaries">Read today's obituaries</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="https://www.legacy.com/obituaries/KVNews/"  target="_blank" rel="noopener" class="nav-link tnt-section-read-older-obituaries">Read older obituaries</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-11" data-target="#mobile-nav-right_menu-child-11">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a tabindex="-1" aria-hidden="true" href="https://issuu.com/dailyrecord/"  target="_blank" rel="noopener" class="nav-link tnt-section-magazines">Magazines</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-11" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="https://issuu.com/dailyrecord/stacks/ae1da264aae64592a7047c82569a9b8d"  target="_blank" rel="noopener" class="nav-link tnt-section-real-estate-guide">Real Estate Guide</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="https://issuu.com/dailyrecord"  target="_blank" rel="noopener" class="nav-link tnt-section-special-sections-issuu">Special Sections \ Issuu</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="https://issuu.com/dailyrecord/docs/2020_bokc"  target="_blank" rel="noopener" class="nav-link tnt-section-best-of">Best Of</a>
                        </div>
                    </div></div></div></div>
                <div id="tncms-region-nav-mobile-nav-right-below" class="tncms-region-nav"><div id="mobile-nav-right-below_menu" class="panel-group nav navbar-nav" role="tablist" aria-hidden="true"><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right-below_menu-child-1" data-target="#mobile-nav-right-below_menu-child-1">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a tabindex="-1" aria-hidden="true" href="/classifieds"  class="nav-link tnt-section-classifieds">Classifieds</a>
                        </div>
                    </div><ul id="mobile-nav-right-below_menu-child-1" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="http://local.dailyrecordnews.com/"  target="_blank" rel="noopener" class="nav-link tnt-section-marketplace">Marketplace</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/classifieds"  class="nav-link tnt-section-classified-ads">Classified Ads</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="https://classadz.vdata.com/EllensburgDailyRecord/Advertising/Advertiser"  target="_blank" rel="noopener" class="nav-link tnt-section-place-classified-ad">Place classified ad</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="http://jobs.dailyrecordnews.com"  target="_blank" rel="noopener" class="nav-link tnt-section-jobs">Jobs</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/classifieds/housing/rent"  class="nav-link tnt-section-rentals">Rentals</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/real-estate-guide/"  class="nav-link tnt-section-real-estate-guide">Real Estate Guide</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/classifieds/housing/sale"  class="nav-link tnt-section-homes">Homes</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/classifieds/vehicle"  class="nav-link tnt-section-autos">Autos</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="http://jobs.thejobnetwork.com/Login"  target="_blank" rel="noopener" class="nav-link tnt-section-post-your-resume">Post your resume</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/classifieds/community/announcements/legal/"  class="nav-link tnt-section-legals">Legals</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/classifieds/sale/sale/garage/"  class="nav-link tnt-section-garage-sale-map">Garage Sale Map</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/newspaper/"  class="nav-link tnt-section-map-of-newsstands">Map of newsstands</a>
                                </li></ul></div></div></div>
                <div id="tncms-region-mobile-nav-bottom-right-region" class="tncms-region "></div>
            </aside>
        

        <div class="offcanvas-inner">
            <div class="offcanvas-close-btn hidden-md hidden-lg"></div>
    

    
        <div id="site-top-nav-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-top-nav" class="container">
                <div class="row">
                    <div id="topbar-col-one" class="col-md-6 col-sm-6"><div id="tncms-region-topbar-col-one" class="tncms-region "><div id="tncms-block-1841569" class="tncms-block"><div class="tnt-ads-container text-center "><div style="min-height:px; min-width:px;" class="tnt-ads dfp-ad" data-dfp-adunit="/94837440/ellensburg/drn/opinion/nation_of_mike" id="ad-1841569" data-lazy="true"></div></div>
    
</div></div><div id="tncms-region-nav-topbar-col-one-nav" class="tncms-region-nav"><ul id="topbar-col-one-nav_menu" class="list-inline nav-list" ><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-subscriber-services"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/subscriptions/"  tabindex="0">
                    
                        <span class="fas tnt-caret-1"></span>
                    <span class="nav-label">Subscriber Services</span>
                </a><ul id="topbar-col-one-nav_menu-child-1" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-manage-your-subscription"  href="/managesubscription"  tabindex="0">
                    <span class="nav-label">Manage your subscription</span>
                </a></li><li>
                <a class="nav-link   tnt-section-start-a-subscription"  href="/subscriptions/"  tabindex="0">
                    <span class="nav-label">Start a subscription</span>
                </a></li></ul></li><li>
                <a class="nav-link   tnt-section-access-e-edition"  href="/eedition"  tabindex="0">
                    <span class="nav-label">Access e-Edition</span>
                </a></li></ul></div></div>
    <div id="topbar-col-two" class="col-md-6 col-sm-6"><div id="tncms-region-topbar-col-two" class="tncms-region "><div id="tncms-block-1266574" class="tncms-block pull-right"><div id="user-controls-1266574" class="user-controls show-onload clearfix default"><div class="not-logged-in">
        <ul class="list-inline"><li><a href="/tncms/auth/begin/?provider=Newzware&return=https%3A%2F%2Fwww.dailyrecordnews.com%2Fopinion%2Fnation_of_mike%2Fnation-of-mike-itll-work-out-fine-in-the-end%2Farticle_a9acb7ce-fe24-5a01-a44c-001a8d276fbc.html" class="btn btn-link btn-sm user-control-link" rel="nofollow">Sign Up</a></li><li><a href="https://www.dailyrecordnews.com/users/login/?referer_url=https%3A%2F%2Fwww.dailyrecordnews.com%2Fopinion%2Fnation_of_mike%2Fnation-of-mike-itll-work-out-fine-in-the-end%2Farticle_a9acb7ce-fe24-5a01-a44c-001a8d276fbc.html" class="btn btn-primary btn-sm login-btn user-control-link" rel="nofollow">Log In</a></li>
        </ul>
    </div>

    <div class="logged-in">
        
        
            <div class="hide show-offcanvas">
                <ul class="list-inline">
                    <li><a href="https://www.dailyrecordnews.com/users/admin/" class="btn btn-primary btn-sm login-btn user-control-link">Dashboard</a></li>
                    <li> <a class="btn btn-link btn-sm user-control-link" onclick="document.getElementById('user-logout-form-1266574').submit(); return false;" rel="nofollow"> Logout</a></li>
                </ul>
            </div>
        
        <ul class="hide-offcanvas list-inline"><li class="dropdown pull-right">
                
                <div class="dropdown-toggle btn btn-link btn-sm user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><div class="tn-user-avatar pull-left"><!-- user avatar --></div><span class="tn-user-screenname pull-left"></span><b class="caret user-control-link"></b>
                </div>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li role="menuitem"><a href="https://www.dailyrecordnews.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li role="menuitem"><a class="tn-user-profile-url" href="" data-app="https://www.dailyrecordnews.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li role="menuitem"><a href="https://www.dailyrecordnews.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem"><a class="logout-btn" onclick="document.getElementById('user-logout-form-1266574').submit(); return false;" rel="nofollow"><i class="fas tnt-power-off tnt-fw"></i> Logout</a></li>
                </ul>
            </li>
            
        </ul>
    </div>
</div>

<form method="post" action="https://www.dailyrecordnews.com/users/logout/" id="user-logout-form-1266574"><input type="hidden" name="referer_url" value="https://www.dailyrecordnews.com/opinion/nation_of_mike/nation-of-mike-itll-work-out-fine-in-the-end/article_a9acb7ce-fe24-5a01-a44c-001a8d276fbc.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div></div></div>
                </div>
            </header>
        </div>
    

    
        <div id="site-header-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-header" class="container" role="banner">
                
                <div class="row">
                    <div id="masthead-full-top" class="col-lg-12">
                        <div id="tncms-region-masthead-full-top" class="tncms-region "></div>
                    </div>
                </div>
                <div class="row">
                    
                    <div id="masthead-col-one" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-one" class="tncms-region "><div id="tncms-block-1266566" class="tncms-block"><div id="site-logo-1266566" class="site-logo-container text-left" ><div class="logo-middle">
            <a  href="/"><img 
            
            src="https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/custom/image/f23b70f0-15d8-11e5-8230-6346855d5345.png?resize=200%2C40" 
            srcset="https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/custom/image/f23b70f0-15d8-11e5-8230-6346855d5345.png?resize=150%2C30 150w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/custom/image/f23b70f0-15d8-11e5-8230-6346855d5345.png?resize=200%2C40 200w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/custom/image/f23b70f0-15d8-11e5-8230-6346855d5345.png?resize=225%2C45 225w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/custom/image/f23b70f0-15d8-11e5-8230-6346855d5345.png 300w"
            sizes="(min-width: 1200px) 380px, calc(33.33vw - 30px)"
            
            class=" img-responsive lazyload tnt-prop-img"
            width="300"
            height="60"
            alt="site-logo"></a>
        </div></div></div></div></div>
    <div id="masthead-col-two" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-two" class="tncms-region "><div id="tncms-block-1266531" class="tncms-block hide">
            
               
               <div id='dfp1266531-mobile' class='center-block hidden-lg visible-md visible-sm visible-xs'>
               
               <div class="tnt-ads-container text-center "><div style="min-height:50px; min-width:320px;" class="tnt-ads dfp-ad" data-dfp-adunit="/1512966/kvnews_ROS_leaderboard_320x50" id="ad-1266531-mobile" data-dfp-size="[[320,50]]" data-lazy="true"></div></div>
    
                </div>
            
               
               <div id='dfp1266531-desk' class='center-block visible-lg hidden-md hidden-sm hidden-xs'>
               
                <div class="tnt-ads-container text-center "><div style="min-height:50px; min-width:320px;" class="tnt-ads dfp-ad" data-dfp-adunit="/1512966/kvnews_ROS_leaderboard_320x50" id="ad-1266531-desk" data-dfp-size="[320,50]" data-lazy="true"></div></div>
    
               </div>
            </div><div id="tncms-block-1687543" class="tncms-block"><style>
	subscribe {
		font-family: verdana;
		font-weight: 700;
		font-size: 20px;
		line-height: 30px;
		color: black;
		background-color:orange;
		border:  5px solid orange;
		border-radius: 25px;
		width:250px;
		}
a:link {
  text-decoration: none;
}

a:visited {
  text-decoration: none;
}

a:hover {
  text-decoration: none;
}

a:active {
  text-decoration: none;
}

</style><br><p style="text-align:center;"><a href="/subscribe"><subscribe>SUBSCRIBE NOW!</subscribe></a></p></div></div></div>
    <div id="masthead-col-three" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-three" class="tncms-region "><div id="tncms-block-1829104" class="tncms-block"><a href="https://www.dailyrecordnews.com/coronavirus/message_to_subscribers/" target="_blank" text-decoration="none">
    <div align="right">
		<div style="
			line-height: 12px;
			background-color:#C90C0C;
			border: 5px #C90C0C;
			border-radius: 25px;
			width: 250px;
			margin-top:10px;
			padding-bottom: 5px;
			text-align: center;
			font-family: verdana;
			font-weight: 700;
			font-size: 20px;
			line-height: 25px;
			color: white;
			text-shadow: 2px 2px #787b7d;
			text-decoration: none;">
			Message to
			<br>
			our subscribers
		</div>
	</div>
	</a>
        <br></div><div id="tncms-block-1266570" class="tncms-block"><div class="follow-links-1266570 pull-right">
    
    <section id="block-1266570" class="block emphasis-h3   " ><ul class="list-inline">
        
            <li>
                <a href="https://www.facebook.com/ellensburgdailyrecord" title="Facebook" target="_blank" rel="noopener" class="btn btn-xs btn-link fb">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="https://twitter.com/EllensburgDR" title="Twitter" target="_blank" rel="noopener" class="btn btn-xs btn-link tw">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
        
            <li>
                <a href="http://www.youtube.com/user/dailyrecordnews" title="Youtube" target="_blank" rel="noopener" class="btn btn-xs btn-link yt">
                    <i class="fab tnt-youtube"></i>
                    <span class="sr-only">YouTube</span>
                </a>
            </li>
        
        
        
            <li>
                <a href="https://instagram.com/dailyrecordnews/" title="Instagram" target="_blank" rel="noopener" class="btn btn-xs btn-link is">
                    <i class="fab tnt-instagram"></i>
                    <span class="sr-only">Instagram</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://www.dailyrecordnews.com",
  "sameAs" : ["https://www.facebook.com/ellensburgdailyrecord","https://twitter.com/EllensburgDR","http://www.youtube.com/user/dailyrecordnews","https://instagram.com/dailyrecordnews/"]
}
</script>
<div class="clearfix"></div></div></div></div>
                </div>
                <div class="row">
                    <div id="masthead-full-bottom" class="col-lg-12">
                        <div id="tncms-region-masthead-full-bottom" class="tncms-region "></div>
                    </div>
                </div>
                
            </header>
        </div>
    

    
        <div id="site-navbar-container" class="hidden-print affix-top">
            
            <nav id="main-navigation" class="navbar yamm navbar-default container navbar-static">
                
                <div class="navbar-header">
                    
                    
                    
                        <button type="button" class="visible-sm visible-xs navbar-toggle pull-right" data-toggle="offcanvas" data-target="right">
                            <span class="sr-only">Toggle navigation</span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                        </button>
                    

                    
                        <div class="navbar-brand hidden-md hidden-lg pos_right">
                            
                                <div id="tncms-region-main-nav-brand" class="tncms-region "><div id="tncms-block-1266567" class="tncms-block"><div id="site-logo-1266567" class="site-logo-container text-left" ><div class="logo-middle">
            <a  href="/"><img 
            
            src="https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/custom/image/e1981558-1544-11e5-888f-47acbd639baf.png?resize=200%2C33" 
            srcset="https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/custom/image/e1981558-1544-11e5-888f-47acbd639baf.png?resize=150%2C25 150w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/custom/image/e1981558-1544-11e5-888f-47acbd639baf.png 200w"
            sizes="100vw"
            
            class=" img-responsive lazyload tnt-prop-img"
            width="180"
            height="30"
            alt="site-logo"></a>
        </div></div></div></div>
                            
                        </div>
                    

                                    
                </div>

                
                    <div id="navbar-collapse" class="navbar-collapse collapse">
                        
                            <div class="pull-right">
                                <div id="tncms-region-main-nav-right-region" class="tncms-region "><div id="tncms-block-1266547" class="tncms-block"><div id="weather-1266547" class="weather-current pull-right has-ad">
    <ul class="nav navbar-nav navbar-right">
        <li class="current-conditions dropdown">
            <a href="/weather/?weather_zip=98926" class="dropdown-toggle" data-toggle="dropdown" data-hover="dropdown">
                <span class="icon pull-left">
                    
                    <span class="wi-day-sunny"></span>
                </span>
                <span class="pull-left temp-desc nav">
                    <span class="temp">56&deg;</span>
                    
                </span>
                <span class="clearfix"></span>
            </a>
            
                <ul class="dropdown-menu" role="menu" aria-labelledby="weatherExpanded">
                    <li>
                        <div class="weather-expanded">
                            <form action="/weather/" class="zip-update-form form-inline" method="get">
                                <input type="text" class="zip-update form-control" name="zip_code" value="98926"> <input class="btn btn-primary" type="submit" value="GO">
                            </form>
                            
                            <a href="#" class="pull-right zip-update-link" onclick="jQuery('#weather-1266547 .zip-update-form').toggle('fast'); return false;"><span class="fa fa-cog"></span></a>
                            
                            <h4 class="city-title"><i class="fa fa-map-marker"></i> 
                                
                                    Ellensburg, WA
                                
                                 <small>(98926)</small>
                            </h4>
                            <h5>Today</h5>
                            <p>Sunny this morning then becoming cloudy during the afternoon. High 66F. NW winds at less than 5 mph, increasing to 10 to 20 mph..</p>
                            <h5>Tonight</h5>
                            <p>Partly cloudy skies this evening will become overcast overnight. Low 43F. Winds NW at 10 to 20 mph.</p>
                            <p class="text-center"><small><i class="fa fa-info-circle"></i> Updated: April 3, 2021 @ 12:04 pm</small></p>
                        </div>
                    </li>
                    
                    <li>
                     <div style='width:300px;background-color:white;' class="text-center">
                        <div class="tnt-ads-container text-center "><div style="min-height:30px; min-width:250px;" class="tnt-ads dfp-ad" data-dfp-adunit="kvnews_WEATHER-250x30" id="ad-1266547" data-dfp-size="[[250,30]]" data-lazy="true"></div></div>
    
                     </li>
                    
                    <li role="presentation" class="divider"></li>
                    <li class="forecast-link text-center"><a href="/weather/?weather_zip=98926"><i class="fa fa-caret-right"></i> Full Forecast</a></li>
                </ul>
              
            
            
        </li>
    </ul>
</div>

<style> 
    #weather-1266547 .list-unstyled { margin:0; }
    #weather-1266547 span { display: block; }
    #weather-1266547 .forecast-link a {padding: 8px;margin-top: -10px;}
    #weather-1266547 .icon { 
        position: relative;
        
            font-size: 24px; 
            margin-right: 10px; 
        
    }
    #weather-1266547 .temp { 
        
            font-size: 18px; 
            
        
        font-weight: bold; 
    }
    #weather-1266547 .cond { opacity: 0.7; }
    #weather-1266547 .current-conditions { 
        float: left; 
         
            height: 24px;
        
    }
    
    #weather-1266547 .dropdown-toggle { color: #fff; }
    
    
        #weather-1266547 .city-title { padding-top: 5px; }
        #weather-1266547 .weather-expanded { padding: 0 15px; width: 300px; font-weight: normal; }
        #weather-1266547 .weather-expanded h5 { border-top: 1px solid rgba(0,0,0,.05); padding-top: 10px; }
        #weather-1266547 .weather-expanded small { opacity: 0.5; }
        #weather-1266547 .zip-update-form {
            width: 140px;
            margin-top: -54px;
            
                background-color: #eee;
            
            padding: 5px;
            position: absolute;
            display: none;
            right:0;
        }
        #weather-1266547 .zip-update { width: 75px; }
        #weather-1266547 .zip-update-link { color: #999; font-size: 18px; text-decoration: none; }
        #weather-1266547 .zip-update-link:hover { color: #777; }
    
</style></div><div id="tncms-block-1266568" class="tncms-block"><ul id="site-search-1266568-dropdown" class="hidden-print nav navbar-nav navbar-right ">
        <li class="search-form-dropdown dropdown">
            <a  onclick="javascript:void(0); return false;"  class="dropdown-toggle" data-hover="dropdown" data-hover-delay="250" data-toggle="dropdown"><span class="fas tnt-search"></span></a>
            <ul class="dropdown-menu">
                <li><form id="site-search-1266568" aria-labelledby="site-search-button-1266568" action="/search/" method="GET" >
    <input type="hidden" name="l" value="25">
    
        
        <input type="hidden" name="sort" value="relevance">
    
    
    
    
    <input type="hidden" name="f" value="html">
    
        
        <input type="hidden" name="t" value="article,video,youtube,collection">
    
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div class="site-search-form input-group default input-group-sm ">
        <input id="site-search-1266568-term" name="q" title="Site Search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-1266568-btn" class="btn btn-primary" aria-label="Submit Site Search" type="submit">
                
	                <span class="hidden-xl hidden-lg hidden-md fas tnt-search"></span>
	                <span id="site-search-button-1266568" class="hidden-xs hidden-sm">Search</span>
                
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form></ul>
        </li>
    </ul>
 

<script>
    $('#site-search-1266568-btn').on(__tnt.client.clickEvent, function(){
        $('#site-search-1266568').submit();
        return false;
    });

    $('#site-search-1266568').on('submit', function(){
        // Filter query
        var sQueryFiltered = $("#site-search-1266568 input[name=q]").val().replace(/\?/g, '');
    $("#site-search-1266568 input[name=q]").val( sQueryFiltered );

        if( $('#site-search-1266568-term').val() ){
            return true;
        }else{
            return false;
        }
    });</script>
</div></div>
                                <div id="tncms-region-nav-main-nav-right-nav" class="tncms-region-nav"><ul id="main-nav-right-nav_menu" class="nav navbar-nav" role="navigation" aria-label="Main"><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-classifieds"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/classifieds"  tabindex="0">
                    <span class="nav-label">Classifieds</span>
                </a><ul id="main-nav-right-nav_menu-child-1" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-marketplace"  href="http://local.dailyrecordnews.com/"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Marketplace</span>
                </a></li><li>
                <a class="nav-link   tnt-section-classified-ads"  href="/classifieds"  tabindex="0">
                    <span class="nav-label">Classified Ads</span>
                </a></li><li>
                <a class="nav-link   tnt-section-place-classified-ad"  href="https://classadz.vdata.com/EllensburgDailyRecord/Advertising/Advertiser"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Place classified ad</span>
                </a></li><li>
                <a class="nav-link   tnt-section-jobs"  href="http://jobs.dailyrecordnews.com"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Jobs</span>
                </a></li><li>
                <a class="nav-link   tnt-section-rentals"  href="/classifieds/housing/rent"  tabindex="0">
                    <span class="nav-label">Rentals</span>
                </a></li><li>
                <a class="nav-link   tnt-section-real-estate-guide"  href="/real-estate-guide/"  tabindex="0">
                    <span class="nav-label">Real Estate Guide</span>
                </a></li><li>
                <a class="nav-link   tnt-section-homes"  href="/classifieds/housing/sale"  tabindex="0">
                    <span class="nav-label">Homes</span>
                </a></li><li>
                <a class="nav-link   tnt-section-autos"  href="/classifieds/vehicle"  tabindex="0">
                    <span class="nav-label">Autos</span>
                </a></li><li>
                <a class="nav-link   tnt-section-post-your-resume"  href="http://jobs.thejobnetwork.com/Login"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Post your resume</span>
                </a></li><li>
                <a class="nav-link   tnt-section-legals"  href="/classifieds/community/announcements/legal/"  tabindex="0">
                    <span class="nav-label">Legals</span>
                </a></li><li>
                <a class="nav-link   tnt-section-garage-sale-map"  href="/classifieds/sale/sale/garage/"  tabindex="0">
                    <span class="nav-label">Garage Sale Map</span>
                </a></li><li>
                <a class="nav-link   tnt-section-map-of-newsstands"  href="/newspaper/"  tabindex="0">
                    <span class="nav-label">Map of newsstands</span>
                </a></li></ul></li></ul></div>
                            </div>
                        
                        <div class="navbar-left">
                            <div id="tncms-region-nav-main-nav" class="tncms-region-nav"><ul id="main-nav_menu" class="nav navbar-nav" role="navigation" aria-label="Main"><li class="dropdown" aria-expanded="false">
                <a class="nav-link  nav-home dropdown-toggle  tnt-section-home"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/"  tabindex="0">
                    <span class="nav-icon fas tnt-home tnt-fw"></span> <span class="nav-label">Home</span>
                </a><ul id="main-nav_menu-child-1" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-contact-us"  href="/site/contact"  tabindex="0">
                    <span class="nav-label">Contact Us</span>
                </a></li><li>
                <a class="nav-link   tnt-section-ownlocal-businesses"  href="http://local.dailyrecordnews.com/"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">OwnLocal Businesses</span>
                </a></li><li>
                <a class="nav-link   tnt-section-subscribe-today"  href="/subscribe/"  tabindex="0">
                    <span class="nav-label">Subscribe today!</span>
                </a></li><li>
                <a class="nav-link   tnt-section-2020-rate-card"  href="https://issuu.com/dailyrecord/docs/rate_card_daily_record_2020"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">2020 Rate Card</span>
                </a></li></ul></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-news"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/news"  tabindex="0">
                    <span class="nav-label">News</span>
                </a><ul id="main-nav_menu-child-2" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-wa-wildfires"  href="/wildfire/"  tabindex="0">
                    <span class="nav-label">WA Wildfires</span>
                </a></li><li>
                <a class="nav-link   tnt-section-local-news"  href="/news"  tabindex="0">
                    <span class="nav-label">Local News</span>
                </a></li><li>
                <a class="nav-link   tnt-section-uppercounty"  href="/uppercounty/"  tabindex="0">
                    <span class="nav-label">Uppercounty</span>
                </a></li><li>
                <a class="nav-link   tnt-section-in-brief"  href="/inbrief/"  tabindex="0">
                    <span class="nav-label">In Brief</span>
                </a></li><li>
                <a class="nav-link   tnt-section-election-2020"  href="/election"  tabindex="0">
                    <span class="nav-label">Election 2020</span>
                </a></li><li>
                <a class="nav-link   tnt-section-police-blotter"  href="/blotter/"  tabindex="0">
                    <span class="nav-label">Police Blotter</span>
                </a></li><li>
                <a class="nav-link   tnt-section-state-news"  href="/news/state/"  tabindex="0">
                    <span class="nav-label">State News</span>
                </a></li><li>
                <a class="nav-link   tnt-section-national-news"  href="/news/national/"  tabindex="0">
                    <span class="nav-label">National News</span>
                </a></li><li>
                <a class="nav-link   tnt-section-weather"  href="/weather"  tabindex="0">
                    <span class="nav-label">Weather</span>
                </a></li><li>
                <a class="nav-link   tnt-section-garden-of-the-month-form"  href="/garden-of-the-month-form/pdf_f7ee68fa-a6bc-11e2-89b2-001a4bcf887a.html"  tabindex="0">
                    <span class="nav-label">Garden of the Month Form</span>
                </a></li><li>
                <a class="nav-link   tnt-section-buy-news-photos"  href="//kvnews.mycapture.com/mycapture/index.asp?"  tabindex="0">
                    <span class="nav-label">Buy News Photos</span>
                </a></li><li>
                <a class="nav-link   tnt-section-photos"  href="/gallery"  tabindex="0">
                    <span class="nav-label">Photos</span>
                </a></li><li>
                <a class="nav-link   tnt-section-videos"  href="/videos"  tabindex="0">
                    <span class="nav-label">Videos</span>
                </a></li><li>
                <a class="nav-link   tnt-section-search"  href="/search"  tabindex="0">
                    <span class="nav-label">Search</span>
                </a></li><li>
                <a class="nav-link   tnt-section-submit-news"  href="/site/forms/submit/news/"  tabindex="0">
                    <span class="nav-label">Submit News</span>
                </a></li><li>
                <a class="nav-link   tnt-section-archives-1880-2004"  href="http://goo.gl/FrqUp"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Archives:  1880-2004</span>
                </a></li><li>
                <a class="nav-link   tnt-section-i-classfa-fa-photoi-photo-galleries"  href="/gallery"  tabindex="0">
                    <span class="nav-label"><i class='fa fa-photo'></i> Photo Galleries</span>
                </a></li></ul></li><li>
                <a class="nav-link   tnt-section-covid-19"  href="/coronavirus/"  tabindex="0">
                    <span class="nav-label">COVID-19</span>
                </a></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-newsletters"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"    tabindex="0">
                    <span class="nav-label">Newsletters</span>
                </a><ul id="main-nav_menu-child-4" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-monday"  href="/newsletter/monday/"  tabindex="0">
                    <span class="nav-label">Monday</span>
                </a></li></ul></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-rodeo"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/rodeo/"  tabindex="0">
                    <span class="nav-label">Rodeo</span>
                </a><ul id="main-nav_menu-child-5" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-rodeo-news"  href="/rodeo/"  tabindex="0">
                    <span class="nav-label">Rodeo News</span>
                </a></li><li>
                <a class="nav-link   tnt-section-schedule"  href="/rodeo/schedule/"  tabindex="0">
                    <span class="nav-label">Schedule</span>
                </a></li></ul></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-sports"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/sports"  tabindex="0">
                    <span class="nav-label">Sports</span>
                </a><ul id="main-nav_menu-child-6" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-sports"  href="/sports"  tabindex="0">
                    <span class="nav-label">Sports</span>
                </a></li><li>
                <a class="nav-link   tnt-section-cwu-wildcats"  href="/sports/cwu_wildcats/"  tabindex="0">
                    <span class="nav-label">CWU Wildcats</span>
                </a></li><li>
                <a class="nav-link   tnt-section-rodeo"  href="/rodeo/"  tabindex="0">
                    <span class="nav-label">Rodeo</span>
                </a></li><li>
                <a class="nav-link   tnt-section-submit-sports-news"  href="/site/forms/submit/sports/"  tabindex="0">
                    <span class="nav-label">Submit Sports News</span>
                </a></li><li>
                <a class="nav-link   tnt-section-buy-sports-photo"  href="//kvnews.mycapture.com/mycapture/index.asp?"  tabindex="0">
                    <span class="nav-label">Buy Sports Photo</span>
                </a></li><li>
                <a class="nav-link   tnt-section-ap-auto-racing"  href="/sports/ap_auto/"  tabindex="0">
                    <span class="nav-label">AP Auto Racing</span>
                </a></li><li>
                <a class="nav-link   tnt-section-ap-college-basketball"  href="/sports/ap_cbasketball/"  tabindex="0">
                    <span class="nav-label">AP College Basketball</span>
                </a></li><li>
                <a class="nav-link   tnt-section-ap-college-football"  href="/sports/ap_cfootball/"  tabindex="0">
                    <span class="nav-label">AP College Football</span>
                </a></li><li>
                <a class="nav-link   tnt-section-seattle-seahawks-ap"  href="/sports/seahawks/"  tabindex="0">
                    <span class="nav-label">Seattle Seahawks [AP]</span>
                </a></li><li>
                <a class="nav-link   tnt-section-seattle-mariners-ap"  href="/sports/mariners/"  tabindex="0">
                    <span class="nav-label">Seattle Mariners [AP]</span>
                </a></li><li>
                <a class="nav-link   tnt-section-seattle-sounders-ap"  href="/sports/sounders/"  tabindex="0">
                    <span class="nav-label">Seattle Sounders [AP]</span>
                </a></li><li>
                <a class="nav-link   tnt-section-seattle-storm-ap"  href="/sports/storm/"  tabindex="0">
                    <span class="nav-label">Seattle Storm [AP]</span>
                </a></li></ul></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-features"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"    tabindex="0">
                    <span class="nav-label">Features</span>
                </a><ul id="main-nav_menu-child-7" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-business"  href="/business"  tabindex="0">
                    <span class="nav-label">Business</span>
                </a></li><li>
                <a class="nav-link   tnt-section-religion"  href="/religion/"  tabindex="0">
                    <span class="nav-label">Religion</span>
                </a></li><li>
                <a class="nav-link   tnt-section-outdoors"  href="/outdoors/"  tabindex="0">
                    <span class="nav-label">Outdoors</span>
                </a></li><li>
                <a class="nav-link   tnt-section-family-education"  href="/familyandeducation/"  tabindex="0">
                    <span class="nav-label">Family & Education</span>
                </a></li><li>
                <a class="nav-link   tnt-section-weekend-life"  href="/weekendlife/"  tabindex="0">
                    <span class="nav-label">Weekend Life</span>
                </a></li><li>
                <a class="nav-link   tnt-section-scrapbook"  href="/scrapbook/"  tabindex="0">
                    <span class="nav-label">Scrapbook</span>
                </a></li><li>
                <a class="nav-link   tnt-section-parade-magazine"  href="http://www.parade.com"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Parade Magazine</span>
                </a></li><li>
                <a class="nav-link   tnt-section-submit-business-news"  href="/site/forms/online_services/submit_business_news/"  tabindex="0">
                    <span class="nav-label">Submit Business News</span>
                </a></li><li>
                <a class="nav-link   tnt-section-ownlocal-market-place"  href="http://local.dailyrecordnews.com/"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">OwnLocal Market Place</span>
                </a></li><li>
                <a class="nav-link   tnt-section-kittitas-county-real-estate"  href="http://kittitascountyrealestate.com/"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Kittitas County Real Estate</span>
                </a></li></ul></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-opinion"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/opinion"  tabindex="0">
                    <span class="nav-label">Opinion</span>
                </a><ul id="main-nav_menu-child-8" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-editorial"  href="/opinion/editorial/"  tabindex="0">
                    <span class="nav-label">Editorial</span>
                </a></li><li>
                <a class="nav-link   tnt-section-letters-to-the-editor"  href="/opinion/letters_to_the_editor/"  tabindex="0">
                    <span class="nav-label">Letters to the Editor</span>
                </a></li><li>
                <a class="nav-link   tnt-section-guest-columns"  href="/opinion/guest_columns/"  tabindex="0">
                    <span class="nav-label">Guest Columns</span>
                </a></li><li>
                <a class="nav-link   tnt-section-nation-of-mike"  href="/opinion/nation_of_mike/"  tabindex="0">
                    <span class="nav-label">Nation of Mike</span>
                </a></li><li>
                <a class="nav-link   tnt-section-submit-a-letter-to-the-editor"  href="/site/forms/submit/letters/"  tabindex="0">
                    <span class="nav-label">Submit a letter to the editor</span>
                </a></li><li>
                <a class="nav-link   tnt-section-submit-thumbs-up-down"  href="/site/forms/submit/thumbs/"  tabindex="0">
                    <span class="nav-label">Submit Thumbs Up Down</span>
                </a></li></ul></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-calendar"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/calendar"  tabindex="0">
                    <span class="nav-label">Calendar</span>
                </a><ul id="main-nav_menu-child-9" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-submit-calendar-item"  href="https://portal.cityspark.com/EventEntry/EventEntry/EllensburgDailyRecord"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Submit Calendar Item</span>
                </a></li><li>
                <a class="nav-link   tnt-section-community-events"  href="/calendar"  tabindex="0">
                    <span class="nav-label">Community Events</span>
                </a></li></ul></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-obituaries"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"    tabindex="0">
                    <span class="nav-label">Obituaries</span>
                </a><ul id="main-nav_menu-child-10" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-submit-an-obituary"  href="//selfserve.dailyrecordnews.com/dailyrecord-adportal/obits/index.html"  tabindex="0">
                    <span class="nav-label">Submit an obituary</span>
                </a></li><li>
                <a class="nav-link   tnt-section-read-todays-obituaries"  href="https://www.legacy.com/obituaries/kvnews/"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Read today's obituaries</span>
                </a></li><li>
                <a class="nav-link   tnt-section-read-older-obituaries"  href="https://www.legacy.com/obituaries/KVNews/"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Read older obituaries</span>
                </a></li></ul></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-magazines"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="https://issuu.com/dailyrecord/"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Magazines</span>
                </a><ul id="main-nav_menu-child-11" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-real-estate-guide"  href="https://issuu.com/dailyrecord/stacks/ae1da264aae64592a7047c82569a9b8d"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Real Estate Guide</span>
                </a></li><li>
                <a class="nav-link   tnt-section-special-sections-issuu"  href="https://issuu.com/dailyrecord"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Special Sections \ Issuu</span>
                </a></li></ul></li><li>
                <a class="nav-link   tnt-section-best-of"  href="https://issuu.com/dailyrecord/docs/2020_bokc"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Best Of</span>
                </a></li></ul></div>
                        </div>
                    </div>
                

                
            </nav>
            
        </div>
        
            
                <script>
                    jQuery(document).ready(function($){
                        var sNavContainer = '#site-navbar-container';
                        var sBodyContainer = '#main-body-container';
                        var sNavHeight = $(sNavContainer).height();
                        var iUnfixPoint = 0;
                        if( __tnt.client.platform.ios ){
                            $(sNavContainer).addClass('affix-sticky');
                        } else {
                            $sNavScroll = false;
                            $(window).on('scroll mousewheel', function(){
                                if( !$sNavScroll ){
                                    $sNavScroll = true;
                                    setTimeout(function(){
                                        var iFixPoint = $(sNavContainer).offset().top;
                                        var iCurrPoint = $(this).scrollTop();
                                        if( iCurrPoint >= iFixPoint && iCurrPoint > iUnfixPoint ){
                                            if( !$(sNavContainer).hasClass('affix') ){ 
                                                iUnfixPoint = iFixPoint;
                                                $(sNavContainer).addClass('affix').removeClass('affix-top');
                                                $(sBodyContainer).css('margin-top', sNavHeight+'px'); 
                                            }
                                        } else {
                                            if( !$(sNavContainer).hasClass('affix-top') ){ 
                                                $(sNavContainer).removeClass('affix').addClass('affix-top');
                                                $(sBodyContainer).css('margin-top', 0);
                                            }
                                        }
                                        $sNavScroll = false;
                                    }, 25);
                                }
                            });
                        }
                    });
                </script>
            
        
    
    <div id="main-body-container">
    <section id="main-top-container" class="container-fullscreen-region container-fluid">
        
        <div class="fullscreen-region"><div id="tncms-region-global-container-top-fullscreen" class="tncms-region "><div id="tncms-block-1503250" class="tncms-block"><div class="tnt-ads-container text-center "><div style="min-height:1px; min-width:1px;" class="tnt-ads dfp-ad" data-dfp-adunit="/94837440/ellensburg/drn/opinion/nation_of_mike" id="ad-1503250" data-dfp-size="[1,1]" data-lazy="true"></div></div>
    
</div></div></div>
    </section>
    <section id="main-page-container" class="container">
        <div class="row">
                <div id="asset-container-top" class="col-md-12"><div id="tncms-region-asset_container_top" class="tncms-region hidden-print"></div></div>
            
            <div class="col-md-12"><div id="tncms-region-global-container-top" class="tncms-region "><div id="tncms-block-1266507" class="tncms-block"></div><div id="tncms-block-1276020" class="tncms-block hidden-sm hidden-xs"><div class="tnt-ads-container text-center "><div style="min-height:90px; min-width:728px;" class="tnt-ads dfp-ad" data-dfp-adunit="/94837440/ellensburg/drn/opinion/nation_of_mike" data-dfp-custom-pos="png_top" id="ad-1276020" data-dfp-size="[728, 90]" data-lazy="true"></div></div>
    
</div><div id="tncms-block-1276027" class="tncms-block hidden-lg hidden-md"><div class="tnt-ads-container text-center "><div style="min-height:50px; min-width:320px;" class="tnt-ads dfp-ad" data-dfp-adunit="/94837440/ellensburg/drn/opinion/nation_of_mike" data-dfp-custom-pos="png_top" id="ad-1276027" data-dfp-size="[320,50]" data-lazy="true"></div></div>
    
</div><div id="tncms-block-1830398" class="tncms-block tnc-overlay"><div class="modal promo-designer-modal in centered " id="promo-designer-modal-custom-pop" tabindex="-1" role="dialog" aria-label="Promotional pop up" aria-hidden="true" >
        <div class="modal-dialog modal-md centered">
            <div class="modal-content">
                <div class="modal-body"><section id="block-1830398" class="block emphasis-h3   " ><div class="promo-design"><div class="card-bg-color rounded_rectangle">
        <div class="card-panel panel"><button type="button" class="close" data-dismiss="modal" aria-label="Close">
                <span class="tnt-stack" aria-hidden="true">
                    <i class="fas tnt-circle tnt-inverse tnt-stack-1x"></i>
                    <i class="fas tnt-times-circle tnt-stack-1x"></i>
                </span>
            </button>
             <div class="panel-body">
                <div class="promo-designer-wrapper">
                    
                        <div class="headline large light text-shadow">
                            Support local journalism
                        </div>
                    
                    
                        <p class="text light text-shadow">
                            Now, more than ever, the world needs trustworthy reporting—but good journalism isn’t free. Please support us by making a contribution.
                        </p>
                    <div class="promo-design-button">
                            <a href="/contribute">
                                <button type="button" class="btn btn-danger btn-lg">Contribute</button>
                            </a>
                        </div>
                </div>   
            </div>
        </div>
    </div>
</div></section></div>
            </div>
        </div>
    </div></div></div></div>
        </div><div id="modal-image-eba9d3b3-a3e2-548b-8709-222a26d2a9c0" class="modal fullscreen in modal-image image-default modal-eba9d3b3-a3e2-548b-8709-222a26d2a9c0" role="dialog" aria-hidden="true" data-lazy-content>
        <template>
            <button type="button" class="close hidden-print" data-dismiss="modal">
                <span aria-hidden="true" class="control-left fas tnt-times-circle"></span>
                <span class="sr-only">Close</span>
            </button>
            <div class="modal-dialog modal-lg">
                <div class="modal-content">
                    <div class="modal-body">
                        <div class="modal-image-container"><figure class="photo layout-vertical letterbox-style-default">
            <div class="image" 
                >
                
                
                
                
        <img
                    src="https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/e/ba/eba9d3b3-a3e2-548b-8709-222a26d2a9c0/5f2dad9aab1fa.image.jpg"
                    srcset="https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/e/ba/eba9d3b3-a3e2-548b-8709-222a26d2a9c0/5f2dad9aab1fa.image.jpg?resize=150%2C223 150w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/e/ba/eba9d3b3-a3e2-548b-8709-222a26d2a9c0/5f2dad9aab1fa.image.jpg?resize=200%2C297 200w"
                    sizes="100vw"
                    
                    width="200"
                    height="297"
                    alt="Michael Gallagher"
                    class="img-responsive true-size default" />
                
                
            </div>
            
                
                
            
        </figure></div>
                    </div>
                </div>
            </div>
            <div class="modal-caption">
        <div class="caption-container">
                <span class="pull-right photo-carousel-caption-toggle" data-toggle="collapse" data-instance="#carousel-modal-image-eba9d3b3-a3e2-548b-8709-222a26d2a9c0" data-target=".caption-inner-modal-image-eba9d3b3-a3e2-548b-8709-222a26d2a9c0">
                    <i class="fas tnt-minus-circle"></i>
                </span>
            <div class="caption-inner-modal-image-eba9d3b3-a3e2-548b-8709-222a26d2a9c0 collapse in"><div class="caption-text"><div class="subscriber-preview"><p>Michael Gallagher</p></div></div><div class="card-meta">
                        <ul class="list-inline">
                            
                                
                                
                                    <li class="credit"><span  class="tnt-byline">Brian Myrick</span></li>
                                
                            
                            
                            
                        </ul>
                    </div>
                    <div class="photo-share">
                        <ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.dailyrecordnews.com%2Fopinion%2Fnation_of_mike%2Fmichael-gallagher%2Fimage_eba9d3b3-a3e2-548b-8709-222a26d2a9c0.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/opinion/nation_of_mike/michael-gallagher/image_eba9d3b3-a3e2-548b-8709-222a26d2a9c0.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"eba9d3b3-a3e2-548b-8709-222a26d2a9c0"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Michael%20Gallagher&via=EllensburgDR&url=https%3A%2F%2Fwww.dailyrecordnews.com%2Fopinion%2Fnation_of_mike%2Fmichael-gallagher%2Fimage_eba9d3b3-a3e2-548b-8709-222a26d2a9c0.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/opinion/nation_of_mike/michael-gallagher/image_eba9d3b3-a3e2-548b-8709-222a26d2a9c0.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"eba9d3b3-a3e2-548b-8709-222a26d2a9c0"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.dailyrecordnews.com/opinion/nation_of_mike/michael-gallagher/image_eba9d3b3-a3e2-548b-8709-222a26d2a9c0.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/opinion/nation_of_mike/michael-gallagher/image_eba9d3b3-a3e2-548b-8709-222a26d2a9c0.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"eba9d3b3-a3e2-548b-8709-222a26d2a9c0"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.dailyrecordnews.com/tncms/asset/editorial/eba9d3b3-a3e2-548b-8709-222a26d2a9c0" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"eba9d3b3-a3e2-548b-8709-222a26d2a9c0"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BThe%20Daily%20Record%5D%20Michael%20Gallagher&body=https%3A%2F%2Fwww.dailyrecordnews.com%2Fopinion%2Fnation_of_mike%2Fmichael-gallagher%2Fimage_eba9d3b3-a3e2-548b-8709-222a26d2a9c0.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"eba9d3b3-a3e2-548b-8709-222a26d2a9c0"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/opinion/nation_of_mike/michael-gallagher/image_eba9d3b3-a3e2-548b-8709-222a26d2a9c0.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"eba9d3b3-a3e2-548b-8709-222a26d2a9c0"}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-eba9d3b3-a3e2-548b-8709-222a26d2a9c0-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="eba9d3b3-a3e2-548b-8709-222a26d2a9c0" data-tncms-track-dmp='is_saved_items_user'>
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="eba9d3b3-a3e2-548b-8709-222a26d2a9c0" class="save-list-eba9d3b3-a3e2-548b-8709-222a26d2a9c0-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="eba9d3b3-a3e2-548b-8709-222a26d2a9c0" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="images" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>

                    </div>
            </div>
        </div>
    </div>
            <style>
                #modal-image-eba9d3b3-a3e2-548b-8709-222a26d2a9c0 img { max-height: 297px; }
            </style>
        </template>
    </div><article itemscope itemtype="https://schema.org/Article" id="asset-a9acb7ce-fe24-5a01-a44c-001a8d276fbc" class="asset article-default"  data-url="https://www.dailyrecordnews.com/opinion/nation_of_mike/nation-of-mike-itll-work-out-fine-in-the-end/article_a9acb7ce-fe24-5a01-a44c-001a8d276fbc.html">
    <span itemscope itemtype="http://schema.org/SpeakableSpecification">
        <meta itemprop="cssSelector" content=".asset-header .headline" />
        <meta itemprop="cssSelector" content=".asset-content p:first-of-type" />
    </span>
    <meta itemprop="description" content="A while ago my eldest son Aidan, who is away at college, casually mentioned he might be interested in a road bike. "/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
        <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="url" content="https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/e/ba/eba9d3b3-a3e2-548b-8709-222a26d2a9c0/5f2dad9aab1fa.image.jpg?resize=200%2C297">
            <meta itemprop="width" content="200">
            <meta itemprop="height" content="297">
        </div>
        <meta itemprop="name" content="dailyrecordnews.com">
    </div>
    <link itemprop="mainEntityOfPage" href="https://www.dailyrecordnews.com/opinion/nation_of_mike/nation-of-mike-itll-work-out-fine-in-the-end/article_a9acb7ce-fe24-5a01-a44c-001a8d276fbc.html" />
    <div class="asset-paging-container hidden-print" data-settings='{"assetType":"article","hasPageBreak":false,"isObit":false,"nextUrl":"https:\/\/www.dailyrecordnews.com\/tncms\/search\/mlt\/?origin=a9acb7ce-fe24-5a01-a44c-001a8d276fbc&app=editorial&preview=1&type=article%2Ccollection%2Cvideo%2Cyoutube","uuid":"a9acb7ce-fe24-5a01-a44c-001a8d276fbc","isFluid":false,"isAdminVenue":false}'>
            <div id="asset-paging-a9acb7ce-fe24-5a01-a44c-001a8d276fbc" class="asset-paging">
                <div id="paging-prev-a9acb7ce-fe24-5a01-a44c-001a8d276fbc" class="paging-link prev offset"></div>
                <div id="paging-next-a9acb7ce-fe24-5a01-a44c-001a8d276fbc" class="paging-link next offset"></div>
                <div class="clearfix"></div>
            </div>
        </div>
        <template id="asset-paging-template">
            <a class="animate arrow text-center">
                <span class=""></span>
                <span class="animate direction hidden-sm hidden-xs text-primary"></span>
            </a>
            <div class="animate item">
                <div class="dismiss" onclick="document.body.classList.add('trigger-disabled'); document.body.classList.remove('trigger-next'); return false;">
                    <span class="tnt-stack" aria-hidden="true">
                        <i class="fas tnt-circle tnt-inverse tnt-stack-1x"></i>
                        <i class="fas tnt-times-circle tnt-stack-1x"></i>
                    </span>
                </div>
                <div class="inner">
                    <a class="overlay">
                        <span class="sr-only"></span>
                    </a>
                    <div class="head text-uppercase">
                        <small></small>
                    </div>
                    <div class="media">
                        <div class="media-body">
                            <h6 class="media-heading"></h6>
                            <p class="hidden-xs"></p>
                        </div>
                    </div>
                    <div class="clearfix"></div>
                </div>
            </div>
        </template><div class="asset-masthead ">
        <header class="asset-header">
    
    <h1 itemprop="headline" class="headline">
        <span>
            
            Nation of Mike: It'll work out fine in the end
        </span>
    </h1>
    
    <div class="meta">
        <span>
            <ul class="list-inline">
        <li><span itemprop="author" class="tnt-byline">Michael Gallagher
managing editor</span></li>
        
        
            <li class="visible-print">
        <time datetime="2021-04-03T05:15:00-07:00" class="tnt-date asset-date text-muted">
            Apr 3, 2021
        </time></li>
            <li class="hidden-print">
        <time datetime="2021-04-03T05:15:00-07:00" class="tnt-date asset-date text-muted">7 hrs ago</time></li>
        
        
            <li class="hidden-print"><a href="/opinion/nation_of_mike/nation-of-mike-itll-work-out-fine-in-the-end/article_a9acb7ce-fe24-5a01-a44c-001a8d276fbc.html#comments" class="cm"><span class="fas tnt-comments"></span>
            <span class="sr-only">Comments</span>
        </a></li>
        
        
    </ul>
        </span>
    </div>
    <meta itemprop="dateCreated" content="2021-04-03T05:15:00-07:00">
    <meta itemprop="datePublished" content="2021-04-03T05:15:00-07:00">
    <meta itemprop="dateModified" content="2021-04-03T05:15:00-07:00">
</header>
        
        
            <div class="share-container headline-right pull-right hidden-xs" data-subscription-required-remove><ul class="social-share-links hidden-print list-unstyled stacked icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.dailyrecordnews.com%2Fopinion%2Fnation_of_mike%2Fnation-of-mike-itll-work-out-fine-in-the-end%2Farticle_a9acb7ce-fe24-5a01-a44c-001a8d276fbc.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/opinion/nation_of_mike/nation-of-mike-itll-work-out-fine-in-the-end/article_a9acb7ce-fe24-5a01-a44c-001a8d276fbc.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"a9acb7ce-fe24-5a01-a44c-001a8d276fbc"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Share">
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Nation%20of%20Mike%3A%20It%27ll%20work%20out%20fine%20in%20the%20end&via=EllensburgDR&url=https%3A%2F%2Fwww.dailyrecordnews.com%2Fopinion%2Fnation_of_mike%2Fnation-of-mike-itll-work-out-fine-in-the-end%2Farticle_a9acb7ce-fe24-5a01-a44c-001a8d276fbc.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/opinion/nation_of_mike/nation-of-mike-itll-work-out-fine-in-the-end/article_a9acb7ce-fe24-5a01-a44c-001a8d276fbc.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"a9acb7ce-fe24-5a01-a44c-001a8d276fbc"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Tweet">
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.dailyrecordnews.com/opinion/nation_of_mike/nation-of-mike-itll-work-out-fine-in-the-end/article_a9acb7ce-fe24-5a01-a44c-001a8d276fbc.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/opinion/nation_of_mike/nation-of-mike-itll-work-out-fine-in-the-end/article_a9acb7ce-fe24-5a01-a44c-001a8d276fbc.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"a9acb7ce-fe24-5a01-a44c-001a8d276fbc"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="WhatsApp">
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.dailyrecordnews.com/tncms/asset/editorial/a9acb7ce-fe24-5a01-a44c-001a8d276fbc" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"a9acb7ce-fe24-5a01-a44c-001a8d276fbc"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="SMS">
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BThe%20Daily%20Record%5D%20Nation%20of%20Mike%3A%20It%27ll%20work%20out%20fine%20in%20the%20end&body=https%3A%2F%2Fwww.dailyrecordnews.com%2Fopinion%2Fnation_of_mike%2Fnation-of-mike-itll-work-out-fine-in-the-end%2Farticle_a9acb7ce-fe24-5a01-a44c-001a8d276fbc.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"a9acb7ce-fe24-5a01-a44c-001a8d276fbc"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Email">
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li></ul></div>
        
    </div>

    

    <div class="row">
        <div class="main-content col-lg-8 col-md-7 has-sidebar"><div class="main-content-wrap">
            <div id="tncms-region-article_top" class="tncms-region hidden-print"></div>
            
            <div class="asset-photo card"><figure class="photo layout-vertical hover-expand letterbox-style-default"><span class="expand hidden-print"
               
               data-toggle="modal"
                
                    data-target=".modal-eba9d3b3-a3e2-548b-8709-222a26d2a9c0" 
                    >
                       <span class="fas tnt-expand"></span>
                   </span>
            
            <div class="image" 
                 
                    data-toggle="modal" 
                     
                    data-target=".modal-eba9d3b3-a3e2-548b-8709-222a26d2a9c0" 
                    >
                
                
                
                
        <div itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="width" content="200">
            <meta itemprop="height" content="297">
            <meta itemprop="contentUrl" content="https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/e/ba/eba9d3b3-a3e2-548b-8709-222a26d2a9c0/5f2dad9aab1fa.image.jpg">
            <meta itemprop="url" content="https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/e/ba/eba9d3b3-a3e2-548b-8709-222a26d2a9c0/5f2dad9aab1fa.image.jpg">
        <img
                    src="https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/e/ba/eba9d3b3-a3e2-548b-8709-222a26d2a9c0/5f2dad9aab1fa.image.jpg"
                    srcset="https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/e/ba/eba9d3b3-a3e2-548b-8709-222a26d2a9c0/5f2dad9aab1fa.image.jpg?resize=150%2C223 150w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/e/ba/eba9d3b3-a3e2-548b-8709-222a26d2a9c0/5f2dad9aab1fa.image.jpg?resize=200%2C297 200w"
                    sizes="(min-width: 1200px) 750px, (min-width: 992px) calc(66.70vw - 60px), calc(100vw - 30px)"
                    
                    width="200"
                    height="297"
                    alt="Michael Gallagher"
                    class="img-responsive  letterbox tnt-restrict-img-eba9d3b3-a3e2-548b-8709-222a26d2a9c0 default" />
            </div><style>
                .tnt-restrict-img-eba9d3b3-a3e2-548b-8709-222a26d2a9c0 {
                    max-width: 200px;
                }
            </style>
                
                
            </div>
            
                
                
                    <figcaption class="caption">
                            <span class="caption-text">
                                <p>Michael Gallagher</p>
                            </span>
                        
                        
                            <span class="credit">
                                <span  class="tnt-byline">Brian Myrick</span>
                            </span>
                        
                        <span class="clearfix"></span>
                    </figcaption>
                
            
        </figure></div>

            

            

            <div id="tncms-region-article_top_content" class="tncms-region hidden-print"><div id="tncms-block-1830027" class="tncms-block"><div align="center">
      <table style="background-color: #E6E6E6;
                    width: 90%" bordercolor="#E6E6E6" border="0"><tbody><tr><td>
              <div class="emailSignupSpan" style="color:white; padding:10px" align="center">
                <h1 style="color: black;
                           font-weight: 600;">
                  Support Local Journalism </h1>
              </div>
              <center><label for="ssOffer" style="color:black; 
                		  padding:0px
                			font-weight: 100;
											font-size: 18px;"> 
                If you value these stories, please consider subscribing.
                </label></center>
            </td>
            <td width="25%" valign="middle">
              <p><br><a href="/subscribe" text-decoration="none"><font style="font-family: verdana;
									font-weight: 900;
                  font-size: 25px;
									line-height: 20px;
                  color: white;
									background-color:#3980C3;
                  border:  10px solid #3980C3;
									border-radius: 15px;
                  box-shadow: 2px 3px  5px #888888;                                                            text-decoration: none;
             			width:250px;"> Subscribe</font></a></p>
            </td>
          </tr></tbody></table></div>
    <p><br></p></div></div>

            <div id="asset-content" data-asset-uuid="a9acb7ce-fe24-5a01-a44c-001a8d276fbc">
                

                <div class="row">
                    <div class="col-lg-12 col-md-12 col-sm-12" data-subscription-required-class="col-xs-12">
                        
                        <div class="asset-body" data-subscription-required-class="asset-body">
                            
                                <div class="share-container content-above" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.dailyrecordnews.com%2Fopinion%2Fnation_of_mike%2Fnation-of-mike-itll-work-out-fine-in-the-end%2Farticle_a9acb7ce-fe24-5a01-a44c-001a8d276fbc.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/opinion/nation_of_mike/nation-of-mike-itll-work-out-fine-in-the-end/article_a9acb7ce-fe24-5a01-a44c-001a8d276fbc.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"a9acb7ce-fe24-5a01-a44c-001a8d276fbc"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Nation%20of%20Mike%3A%20It%27ll%20work%20out%20fine%20in%20the%20end&via=EllensburgDR&url=https%3A%2F%2Fwww.dailyrecordnews.com%2Fopinion%2Fnation_of_mike%2Fnation-of-mike-itll-work-out-fine-in-the-end%2Farticle_a9acb7ce-fe24-5a01-a44c-001a8d276fbc.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/opinion/nation_of_mike/nation-of-mike-itll-work-out-fine-in-the-end/article_a9acb7ce-fe24-5a01-a44c-001a8d276fbc.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"a9acb7ce-fe24-5a01-a44c-001a8d276fbc"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.dailyrecordnews.com/opinion/nation_of_mike/nation-of-mike-itll-work-out-fine-in-the-end/article_a9acb7ce-fe24-5a01-a44c-001a8d276fbc.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/opinion/nation_of_mike/nation-of-mike-itll-work-out-fine-in-the-end/article_a9acb7ce-fe24-5a01-a44c-001a8d276fbc.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"a9acb7ce-fe24-5a01-a44c-001a8d276fbc"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.dailyrecordnews.com/tncms/asset/editorial/a9acb7ce-fe24-5a01-a44c-001a8d276fbc" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"a9acb7ce-fe24-5a01-a44c-001a8d276fbc"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BThe%20Daily%20Record%5D%20Nation%20of%20Mike%3A%20It%27ll%20work%20out%20fine%20in%20the%20end&body=https%3A%2F%2Fwww.dailyrecordnews.com%2Fopinion%2Fnation_of_mike%2Fnation-of-mike-itll-work-out-fine-in-the-end%2Farticle_a9acb7ce-fe24-5a01-a44c-001a8d276fbc.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"a9acb7ce-fe24-5a01-a44c-001a8d276fbc"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/opinion/nation_of_mike/nation-of-mike-itll-work-out-fine-in-the-end/article_a9acb7ce-fe24-5a01-a44c-001a8d276fbc.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"a9acb7ce-fe24-5a01-a44c-001a8d276fbc"}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-a9acb7ce-fe24-5a01-a44c-001a8d276fbc-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="a9acb7ce-fe24-5a01-a44c-001a8d276fbc" data-tncms-track-dmp='is_saved_items_user'>
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="a9acb7ce-fe24-5a01-a44c-001a8d276fbc" class="save-list-a9acb7ce-fe24-5a01-a44c-001a8d276fbc-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="a9acb7ce-fe24-5a01-a44c-001a8d276fbc" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            

                            
    <!--Tout Top Article Injection Point-->
    <div id="tout_top_container" class="advertisement">
        <div id="tout_above_top_video" style="display:none"></div>
        <div class="tout-sdk tout-top-article hidden-print"></div>
        <div id="tout_below_top_video" style="display:none"></div>
    </div>
    <div id="tncms-region-article_body_top" class="tncms-region hidden-print"></div>

                            <div  itemprop="articleBody" class="asset-content  subscriber-premium">
                                <meta itemprop="isAccessibleForFree" content="false"/>
                                
                                
                                <div class="subscriber-preview"><p>A while ago my eldest son Aidan, who is away at college, casually mentioned he might be interested in a road bike.</p></div><div class="subscriber-preview"><p>This caught my attention because previously he’d far more seriously and repeatedly mentioned he wanted a new mountain bike.</p></div><div class="subscriber-only"><p>For the uninitiated, a road bike is thin and sleek with narrow tires and the curved handle bars — they’re the bikes guys who enjoy wearing spandex tend to ride, which may be why you try not to notice them on the road. Mountain bikes are much bulkier, with better shock absorbers than I had on my first car and fat knobby tires great for climbing hills or riding over pedestrians if you catch one unawares on the sidewalk. They are quite useful bikes.</p></div><div class="tnt-ads-container text-center "><div style="min-height:250px; min-width:300px;" class="tnt-ads dfp-ad dfp-ad-lite" data-dfp-adunit="/94837440/ellensburg/drn/opinion/nation_of_mike" data-dfp-custom-pos="fixed-big-ad-top-asset, atf, 50" id="fixed-big-ad-top-asset" data-dfp-size="[300,250]" data-subscriber="true"></div></div>
    <div id="tncms-region-article_instory_top" class="tncms-region hidden-print"><div id="tncms-block-1906895" class="tncms-block apg-margin-bottom-10">
        <div class='s2nPlayer k-07Gpau9r' data-type='float'></div><script type='text/javascript' src='//embed.sendtonews.com/player3/embedcode.js?fk=07Gpau9r&cid=10530&offsetx=0&offsety=0&floatwidth=400&floatposition=bottom-right' data-type='s2nScript'></script>
    </div></div><div class="subscriber-only"><p>For the past few years, Aidan has been using my mountain bike, a Specialized Rockhopper I bought about 30 years ago. It has none of the gadgetry of modern mountain bikes, but there’s nothing wrong with it. Well, Aidan says one of the brakes no longer works, but otherwise it is perfectly fine.</p></div><div class="subscriber-only"><p>I’ll spare you the details, but the boys and I have engaged in a long-running debate over how much we should spend on bikes. Mountain bikes range from several hundred dollars to several thousand dollars. My position — and this is backed up by the hard science — has been it makes no sense to spend $500 to $1,500 on a bike for a boy ranging from 8 to 18, when you can purchase a bike for $43.75 to $61.43 at the Central surplus sale. (Pro tip: Always bid in odd numbers. No idea why, but you’re more likely to win the bid.)</p></div><div class="subscriber-only"><p>The scenario changes at 18 because that’s when I expect them to buy their own bikes.</p></div><div class="subscriber-only"><p>So Aidan’s willingness to consider a road bike peaked my interest. I had been slightly, mildly bothered by never buying him a nice bike and had sort of tentatively told myself I’d help him buy a bike if he found one he wanted. Road bikes can be spendy, especially if you’re gearing up for the Tour de France, but overall they are more affordable than mountain bikes.</p></div><div class="subscriber-only"><p>The other day I found myself in Ellensburg’s glorious Recycle Shop, not looking for a road bike at all, when I was suddenly stopped dead in my tracks by my childhood.</p></div><div class="subscriber-only"><p>Toward the front of the shop was a lovingly restored Schwinn Traveler 10-speed. I had spent my teen years riding a beautiful blue Schwinn Le Tour. The bikes were similar enough to trigger the hazy memories of my youth. Technically, the Le Tour belonged to my brother, but he moved out and left it behind. As the youngest of six I developed an elaborate set of detailed protocol governing the dispersal of items left behind by my siblings when they moved out — if I wanted what was left, it was mine.</p></div><div class="subscriber-only"><p>I loved that Le Tour. It took me everywhere. And since I didn’t own a car until I was 24, it took me everywhere for a long time.</p></div><div class="subscriber-only"><p>I immediately texted Aidan.</p></div><div class="tnt-ads-container text-center "><div style="min-height:250px; min-width:300px;" class="tnt-ads dfp-ad" data-dfp-adunit="/94837440/ellensburg/drn/opinion/nation_of_mike" data-dfp-custom-pos="fixed-big-ad-middle-asset, stf" id="fixed-big-ad-middle-asset" data-dfp-size="[300,250]" data-lazy="true"></div></div>
    <div id="tncms-region-article_instory_middle" class="tncms-region hidden-print"></div><div class="subscriber-only"><p>“Remember, when you said you really wanted a road bike? I think I found one,” I texted.</p></div><div class="subscriber-only"><p>“I said I might be interested,” he texted back.</p></div><div class="subscriber-only"><p>“I will send you a photo. Think about it,” I texted.</p></div><div class="subscriber-only"><p>I don’t know if he thought about it. Who knows what college kids think about these days? (Actually, I have a decent idea on that one). But I thought about it and the next day, went back to the shop and purchased the bike.</p></div><div class="subscriber-only"><p>I took a photo of his brother standing with the bike and sent it with a text, “If and when you ever graduate, this is your graduation gift. I’m giving it to you early.”</p></div><div class="subscriber-only"><p>“Wow, thanks. I feel blessed,” he texted back.</p></div><div class="subscriber-only"><p>That sounds like a nice response, unless you actually know him.</p></div><div class="subscriber-only"><p>Anyway, I’ve found if you want to give someone something you’re not sure they want, give it as a gift. People feel obligated to keep a gift for at least a year.</p></div><div class="subscriber-only"><p>I think he’ll love the bike if he gives it a chance — it meets his quirky quotient. If not, when he moves out for good he’ll likely leave it behind. This could work out fine in the end.</p></div><div class="subscriber-only"><p><em>Contact managing editor Michael Gallagher at <a href="mailto:mgallagher@kvnews.com">mgallagher@kvnews.com</a></em></p></div><div class="tnt-ads-container text-center "><div style="min-height:250px; min-width:300px;" class="tnt-ads dfp-ad" data-dfp-adunit="/94837440/ellensburg/drn/opinion/nation_of_mike" data-dfp-custom-pos="fixed-big-ad-bottom-asset, btf, 70" id="fixed-big-ad-bottom-asset" data-dfp-size="[300,250]" data-lazy="true"></div></div>
    <div id="tncms-region-article_instory_bottom" class="tncms-region hidden-print"></div>
                                <div id="tncms-region-article_bottom_content" class="tncms-region hidden-print"></div>
                                
                            </div>

                            

                            
    <!--Tout Bottom Article Injection Point-->
    <div id="tout_bottom_container" class="advertisement">
        <div id="tout_above_bottom_video" style="display:none"></div>
        <div class="tout-sdk tout-below-article hidden-print"></div>
        <div id="tout_below_bottom_video" style="display:none"></div>
    </div>
    
    


                            
                                <div class="share-container content-below" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.dailyrecordnews.com%2Fopinion%2Fnation_of_mike%2Fnation-of-mike-itll-work-out-fine-in-the-end%2Farticle_a9acb7ce-fe24-5a01-a44c-001a8d276fbc.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/opinion/nation_of_mike/nation-of-mike-itll-work-out-fine-in-the-end/article_a9acb7ce-fe24-5a01-a44c-001a8d276fbc.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"a9acb7ce-fe24-5a01-a44c-001a8d276fbc"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Nation%20of%20Mike%3A%20It%27ll%20work%20out%20fine%20in%20the%20end&via=EllensburgDR&url=https%3A%2F%2Fwww.dailyrecordnews.com%2Fopinion%2Fnation_of_mike%2Fnation-of-mike-itll-work-out-fine-in-the-end%2Farticle_a9acb7ce-fe24-5a01-a44c-001a8d276fbc.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/opinion/nation_of_mike/nation-of-mike-itll-work-out-fine-in-the-end/article_a9acb7ce-fe24-5a01-a44c-001a8d276fbc.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"a9acb7ce-fe24-5a01-a44c-001a8d276fbc"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.dailyrecordnews.com/opinion/nation_of_mike/nation-of-mike-itll-work-out-fine-in-the-end/article_a9acb7ce-fe24-5a01-a44c-001a8d276fbc.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/opinion/nation_of_mike/nation-of-mike-itll-work-out-fine-in-the-end/article_a9acb7ce-fe24-5a01-a44c-001a8d276fbc.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"a9acb7ce-fe24-5a01-a44c-001a8d276fbc"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.dailyrecordnews.com/tncms/asset/editorial/a9acb7ce-fe24-5a01-a44c-001a8d276fbc" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"a9acb7ce-fe24-5a01-a44c-001a8d276fbc"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BThe%20Daily%20Record%5D%20Nation%20of%20Mike%3A%20It%27ll%20work%20out%20fine%20in%20the%20end&body=https%3A%2F%2Fwww.dailyrecordnews.com%2Fopinion%2Fnation_of_mike%2Fnation-of-mike-itll-work-out-fine-in-the-end%2Farticle_a9acb7ce-fe24-5a01-a44c-001a8d276fbc.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"a9acb7ce-fe24-5a01-a44c-001a8d276fbc"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/opinion/nation_of_mike/nation-of-mike-itll-work-out-fine-in-the-end/article_a9acb7ce-fe24-5a01-a44c-001a8d276fbc.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"a9acb7ce-fe24-5a01-a44c-001a8d276fbc"}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-a9acb7ce-fe24-5a01-a44c-001a8d276fbc-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="a9acb7ce-fe24-5a01-a44c-001a8d276fbc" data-tncms-track-dmp='is_saved_items_user'>
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="a9acb7ce-fe24-5a01-a44c-001a8d276fbc" class="save-list-a9acb7ce-fe24-5a01-a44c-001a8d276fbc-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="a9acb7ce-fe24-5a01-a44c-001a8d276fbc" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            
                        </div>
                        
                    </div></div><!-- /asset-content -->

                <div id="asset-below">
                    

                    

                    

                    

                    

                    
                        <div class="asset-tags hidden-print">
                            <h4>Tags</h4>
                            <ul class="list-inline"><li>
                <a href="/search/?k=%22aidan%22#tncms-source=keyword" class="tag-aidan label label-default" data-tncms-track-dmp='search: aidan'>Aidan</a>
            </li> <li>
                <a href="/search/?k=%22road%20bike%22#tncms-source=keyword" class="tag-road-bike label label-default" data-tncms-track-dmp='search: road-bike'>Road Bike</a>
            </li> <li>
                <a href="/search/?k=%22mountain%20bike%22#tncms-source=keyword" class="tag-mountain-bike label label-default" data-tncms-track-dmp='search: mountain-bike'>Mountain Bike</a>
            </li> <li>
                <a href="/search/?k=%22motor%20vehicle%22#tncms-source=keyword" class="tag-motor-vehicle label label-default" data-tncms-track-dmp='search: motor-vehicle'>Motor Vehicle</a>
            </li> <li>
                <a href="/search/?k=%22transports%22#tncms-source=keyword" class="tag-transports label label-default" data-tncms-track-dmp='search: transports'>Transports</a>
            </li> <li>
                <a href="/search/?k=%22commerce%22#tncms-source=keyword" class="tag-commerce label label-default" data-tncms-track-dmp='search: commerce'>Commerce</a>
            </li> <li>
                <a href="/search/?k=%22economics%22#tncms-source=keyword" class="tag-economics label label-default" data-tncms-track-dmp='search: economics'>Economics</a>
            </li> <li>
                <a href="/search/?k=%22bike%22#tncms-source=keyword" class="tag-bike label label-default" data-tncms-track-dmp='search: bike'>Bike</a>
            </li> <li>
                <a href="/search/?k=%22michael%20gallagher%22#tncms-source=keyword" class="tag-michael-gallagher label label-default" data-tncms-track-dmp='search: michael-gallagher'>Michael Gallagher</a>
            </li> <li>
                <a href="/search/?k=%22photo%22#tncms-source=keyword" class="tag-photo label label-default" data-tncms-track-dmp='search: photo'>Photo</a>
            </li> </ul>
                        </div>
                    

                    

                    

                    

                    

                    

                    

                    

                    <div id="tncms-region-article_bottom" class="tncms-region hidden-print"><div id="tncms-block-1363243" class="tncms-block"><div id="nativo-inside"></div></div></div>

                    <div class="asset-comments hidden-print"><h3>Comments</h3>
    <strong>Keep it Clean.</strong> Please avoid obscene, vulgar, lewd,
racist or sexually-oriented language.<br>
<strong>PLEASE TURN OFF YOUR CAPS LOCK.</strong><br>
<strong>Don&#39;t Threaten.</strong> Threats of harming another
person will not be tolerated.<br>
<strong>Be Truthful.</strong> Don&#39;t knowingly lie about anyone
or anything.<br>
<strong>Be Nice.</strong> No racism, sexism or any sort of -ism
that is degrading to another person.<br>
<strong>Be Proactive.</strong> Use the &#39;Report&#39; link on
each comment to let us know of abusive posts.<br>
<strong>Share with Us.</strong> We&#39;d love to hear eyewitness
accounts, the history behind an article.
    <div id="fb-root"></div>
    <script>
        (function(d, s, id) {
            var js, fjs = d.getElementsByTagName(s)[0];
            if (d.getElementById(id)) return;
            js = d.createElement(s); js.id = id;
            js.src = "//connect.facebook.net/en_US/all.js#xfbml=1&appId=2959550254137794";
            fjs.parentNode.insertBefore(js, fjs);
        }(document, 'script', 'facebook-jssdk'));

    </script>
    <div class="fb-comments" data-href="http://www.dailyrecordnews.com/tncms/asset/editorial/a9acb7ce-fe24-5a01-a44c-001a8d276fbc/" data-num-posts="10" data-width="100%"></div>
    <style>
        .fb_iframe_widget,
        .fb_iframe_widget span,
        .fb_iframe_widget span iframe[style]{
            min-width:100%!important;
            width:100%!important;
        }
    </style>
</div>
                    
                    <div id="tncms-region-article_container_bottom" class="tncms-region hidden-print"></div></div>
            </div>

            

            </div>
        </div><div class="main-sidebar col-lg-4 col-md-5 hidden-print">
                <div class="main-sidebar-wrap">
                    <div id="tncms-region-article_side_top" class="tncms-region hidden-print"></div><div id="tncms-region-asset_side_top" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-primary" class="tncms-region "></div><div id="tncms-region-asset_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-article_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-secondary" class="tncms-region hidden-print"><div id="tncms-block-1276024" class="tncms-block"><div class="tnt-ads-container text-center "><div style="min-height:250px; min-width:300px;" class="tnt-ads dfp-ad" data-dfp-adunit="/94837440/ellensburg/drn/opinion/nation_of_mike" data-dfp-custom-pos="png_top" id="ad-1276024" data-dfp-size="[300, 250]" data-lazy="true"></div></div>
    
</div><div id="tncms-block-1380688" class="tncms-block"><section id="block-1380688" class="block emphasis-h3   " ><div class="clearfix">
    
    <div class="block-title title-1380688 ">
        <div class="block-title-inner">
            <h3>
                
                    <a href="https://issuu.com/dailyrecord/" target="_blank" rel="noopener">
                
                Our Magazines
                
                    </a>
                
            </h3>
        </div>
    </div></div><article class="card promo media"><div class="media-body"><p>Check out our special publications on our Issuu.com stack!</p><a href="https://issuu.com/dailyrecord/" target="_blank" rel="noopener">
                <button type="button" class="btn btn-primary  ">Read more</button>
            </a></div>
</article></section></div><div id="tncms-block-1923758" class="tncms-block"><div id="evvnt-calendar-widget"></div>
<script async defer src="//production-evvnt-plugin-herokuapp-com.global.ssl.fastly.net/evvnt_discovery_plugin_s.js" onload="evvntDiscoveryInit();">
</script><script>
  function evvntDiscoveryInit() {
    evvnt_require("evvnt/discovery_plugin").init({
      api_key: "DAILYRECORDNEWS",
      publisher_id:7118,
      discovery: {
        element: "#evvnt-calendar-widget",
        detail_page_enabled: true,
        widget: true,
        virtual: false,
        map: false,
        category_id: null,
        orientation: "portrait",
        number: 5,
      },
      submission: {
        partner_name: "Daily Record News",
        text: "Promote your event",
      }
   });
 }
</script></div><div id="tncms-block-1266539" class="tncms-block">


<style type="text/css">
/* <![CDATA[ */
.flyerWrapper {
    width: 300px;
    height: 600px;                                                           
    position:relative;
    background-position:center;
    margin: 20px auto;
}
#flyerContainer {
    width: 100%;
    position: relative;
    top: 70px;
    left:5px;                                                            
}
.flyerPreview {
    width: 135px;
    height: 145px;
    text-align: center;
    float:left;
    margin: 5px;
}

.flyerViewAll {
    position:absolute;
    bottom: 10px;
    left: 10px;
}
.flyerViewAll img {
    width: auto;
}
/* ]]> */
</style>

<script type="text/javascript">
/* <![CDATA[ */
$(document).ready(function(){
    var cb=new Date().getTime();
    //only fire this if the page is wider than 960
    if ($(window).width()>960)
    {
        $.ajax({
          url: "/app/shoplocal/flyerFeederV3.php",
          type: "GET",
          data: {type: 'board', board_id: 2}, 
          dataType: "json",
          success: function(response){
            if(response.status=='success')
            {
                var boardWidth=response.board_width;
                var boardHeight=response.board_height;
                var thumbWidth=response.thumb_width;
                var thumbHeight=response.thumb_height;
                var topPadding=response.top_padding;
                
                jQuery.each(response.ads, function (j,ad){
                    var newDiv=$('<div id="flyer_'+ad.id+'" />');
                    newDiv.html("<a class='flyerPreview' data-fancybox-type='iframe' href='/app/shoplocal/flyerFeederV3.php?type=flyer&id="+ad.id+"&_cb="+cb+"' style='width:"+thumbWidth+"px;height:"+thumbHeight+"px;'>"+ad.img+"</a>");
                    $('#flyerContainer').append(newDiv);            
                })
                $("a.flyerPreview").fancybox({
                    'width'          : 810,
                    'height'         : 600, 
                    'autoSize'     : true,
                    'audoResize'     : true,
                    'padding'        : 5,
                    'openEffect'   : 'elastic',
                    'closeEffect'  : 'elastic'
               }); 
                var newDiv=$('<div class="clear" />');
                $('#flyerContainer').append(newDiv);
                $('#flyerWrapper').show();
                $('.flyerWrapper').css('background-image',"url('"+response.widget_background+"')");
                $('.flyerWrapper').css('width',boardWidth+"px");
                $('.flyerWrapper').css('height',boardHeight+"px");
                $('#flyerContainer').css('top',topPadding+"px");
                $('#showallButton').html(response.show_all);
            }
          }
        })
    }
})

/* ]]> */
</script>
<div id='flyerWrapper' class='flyerWrapper' style='display:none;'>
<div id='flyerContainer'>
</div>
<div style='clear:both;height:0'></div>
<div id='flyerViewAll' class='flyerViewAll'><a id='showallButton' href='/app/shoplocal/?boardid=2'></a></div>
</div></div><div id="tncms-block-1266564" class="tncms-block"><section id="block-1266564" class="block emphasis-h3   " ><div class="most-popular">
    <ul class="nav nav-tabs nav-tabs-popular">
        
            <li class="active">
                <a href="#articles-1266564" data-toggle="tab"><i class="far tnt-file-alt" title="Articles"></i><span class="tab-text"> Articles</span></a>
            </li>
        
        
            <li >
                <a href="#images-1266564" data-toggle="tab"><i class="far tnt-image" title="images"></i><span class="tab-text"> Images</span></a>
            </li>
        
        
            <li >
                <a href="#videos-1266564" data-toggle="tab"><i class="fas tnt-play-circle" title="Videos"></i><span class="tab-text"> Videos</span></a>
            </li>
        
        
        
        
    </ul>
    <div class="tab-content">
        
            <div id="articles-1266564" class="tab-pane tab-pane-articles fade in active">
                <h4 class="tab-content-heading">Articles</h4><ul class="tab-content-list bullet-disc "><li><a href="/all_access/fire-alarms-help-save-clymer-museum-potentially-half-of-pearl-street/article_846e9256-bc9c-5b0b-969b-8037ac1be572.html">Fire alarms help save Clymer Museum; potentially half of Pearl Street</a></li><li><a href="/news/new-ellensburg-dance-studio-slated-to-open-on-main-street/article_b570354f-1bdf-55c2-99e8-ff5258134f98.html">New Ellensburg dance studio slated to open on Main Street</a></li><li><a href="/monday/local_news/local-paranormal-investigation-group-offers-services-to-local-home-and-business-owners-free-of-cost/article_bd025c98-fcc7-5595-b7f5-9d07902ab987.html">Local paranormal investigation group offers services to local home and business owners free of cost</a></li><li><a href="/all_access/looking-back-old-ellensburg-general-hospital-for-sale/article_0cb9bc0d-293a-5de6-95e5-cc12be286d95.html">Looking Back: Old Ellensburg General Hospital for sale</a></li><li><a href="/news/city-manager-candidates-introduce-themselves-at-a-public-meet-greet-monday-night/article_862a05cd-6767-522c-b10d-dc648ae97fc7.html">City manager candidates introduce themselves at a public meet & greet Monday night</a></li><li><a href="/ap_news/oregon/police-id-vancouver-man-as-homicide-victim-at-portland-store/article_15c61605-0c5d-55b0-9109-58fbbd5efbbf.html">Police ID Vancouver man as homicide victim at Portland store</a></li><li><a href="/all_access/starting-wednesday-people-need-only-self-attest-to-vaccine-eligibility/article_0de709bd-8b24-5081-9744-387bc2ef09bc.html">Starting Wednesday, people need only self-attest to vaccine eligibility</a></li><li><a href="/monday/local_news/march-29-blotter-pig-crosses-the-street/article_5f842921-94cd-5604-96c2-42f7dddb5a75.html">March 29 blotter: Pig crosses the street</a></li><li><a href="/monday/local_news/prep-roundup-second-wave-of-sports-starts-up-for-ellensburg/article_891da4ae-bd9d-528d-8a02-1507bc4a8e8c.html">Prep roundup: Second wave of sports starts up for Ellensburg</a></li><li><a href="/all_access/johnson-and-johnson-vaccine-clinic-set-for-april-10/article_ea58fc73-c20c-57da-ac25-8d2339701db3.html">Johnson and Johnson vaccine clinic set for April 10</a></li></ul></div>
        
        
            <div id="images-1266564" class="tab-pane tab-pane-images fade in ">
                <h4 class="tab-content-heading">Images</h4><ul class="tab-content-list">
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/ap_news/politics/myanmar-pageant-contender-calls-for-urgent-international-aid/image_18698768-8ad2-5b54-b103-30f6b6210518.html" class="tnt-asset-link" >                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Myanmar pageant contender calls for urgent international aid"
                            class="img-responsive lazyload ap-photo full default"
                            width="1174"
                            height="1174"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/1/86/18698768-8ad2-5b54-b103-30f6b6210518/60607ac64fdab.image.jpg?crop=1174%2C1174%2C295%2C0&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/1/86/18698768-8ad2-5b54-b103-30f6b6210518/60607ac64fdab.image.jpg?crop=1174%2C1174%2C295%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/1/86/18698768-8ad2-5b54-b103-30f6b6210518/60607ac64fdab.image.jpg?crop=1174%2C1174%2C295%2C0&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/1/86/18698768-8ad2-5b54-b103-30f6b6210518/60607ac64fdab.image.jpg?crop=1174%2C1174%2C295%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/1/86/18698768-8ad2-5b54-b103-30f6b6210518/60607ac64fdab.image.jpg?crop=1174%2C1174%2C295%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/1/86/18698768-8ad2-5b54-b103-30f6b6210518/60607ac64fdab.image.jpg?crop=1174%2C1174%2C295%2C0&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/1/86/18698768-8ad2-5b54-b103-30f6b6210518/60607ac64fdab.image.jpg?crop=1174%2C1174%2C295%2C0&resize=640%2C640&order=crop%2Cresize 640w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/1/86/18698768-8ad2-5b54-b103-30f6b6210518/60607ac64fdab.image.jpg?crop=1174%2C1174%2C295%2C0&resize=750%2C750&order=crop%2Cresize 750w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/1/86/18698768-8ad2-5b54-b103-30f6b6210518/60607ac64fdab.image.jpg?crop=1174%2C1174%2C295%2C0&resize=990%2C990&order=crop%2Cresize 990w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/1/86/18698768-8ad2-5b54-b103-30f6b6210518/60607ac64fdab.image.jpg?crop=1174%2C1174%2C295%2C0&resize=1035%2C1035&order=crop%2Cresize 1035w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/1/86/18698768-8ad2-5b54-b103-30f6b6210518/60607ac64fdab.image.jpg?crop=1174%2C1174%2C295%2C0&resize=1174%2C1174&order=crop%2Cresize 1200w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/ap_news/us/oklahoma-court-tosses-5-more-first-degree-murder-convictions/image_d91f1312-f0b1-5059-9008-34a29d94c32d.html" class="tnt-asset-link" >                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Oklahoma court tosses 5 more first-degree murder convictions"
                            class="img-responsive lazyload ap-photo full default"
                            width="983"
                            height="983"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/d/91/d91f1312-f0b1-5059-9008-34a29d94c32d/6066190b017a9.image.jpg?crop=983%2C983%2C0%2C125&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/d/91/d91f1312-f0b1-5059-9008-34a29d94c32d/6066190b017a9.image.jpg?crop=983%2C983%2C0%2C125&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/d/91/d91f1312-f0b1-5059-9008-34a29d94c32d/6066190b017a9.image.jpg?crop=983%2C983%2C0%2C125&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/d/91/d91f1312-f0b1-5059-9008-34a29d94c32d/6066190b017a9.image.jpg?crop=983%2C983%2C0%2C125&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/d/91/d91f1312-f0b1-5059-9008-34a29d94c32d/6066190b017a9.image.jpg?crop=983%2C983%2C0%2C125&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/d/91/d91f1312-f0b1-5059-9008-34a29d94c32d/6066190b017a9.image.jpg?crop=983%2C983%2C0%2C125&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/d/91/d91f1312-f0b1-5059-9008-34a29d94c32d/6066190b017a9.image.jpg?crop=983%2C983%2C0%2C125&resize=640%2C640&order=crop%2Cresize 640w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/d/91/d91f1312-f0b1-5059-9008-34a29d94c32d/6066190b017a9.image.jpg?crop=983%2C983%2C0%2C125&resize=750%2C750&order=crop%2Cresize 750w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/d/91/d91f1312-f0b1-5059-9008-34a29d94c32d/6066190b017a9.image.jpg?crop=983%2C983%2C0%2C125&resize=983%2C983&order=crop%2Cresize 990w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/ap_news/politics/general-says-attacks-by-foreign-hackers-are-clarion-call/image_ad8bdc86-56ba-5185-8034-369749f41e05.html" class="tnt-asset-link" >                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="General says attacks by foreign hackers are 'clarion call'"
                            class="img-responsive lazyload ap-photo full default"
                            width="1175"
                            height="1175"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/a/d8/ad8bdc86-56ba-5185-8034-369749f41e05/605ce4c71889f.image.jpg?crop=1175%2C1175%2C294%2C0&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/a/d8/ad8bdc86-56ba-5185-8034-369749f41e05/605ce4c71889f.image.jpg?crop=1175%2C1175%2C294%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/a/d8/ad8bdc86-56ba-5185-8034-369749f41e05/605ce4c71889f.image.jpg?crop=1175%2C1175%2C294%2C0&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/a/d8/ad8bdc86-56ba-5185-8034-369749f41e05/605ce4c71889f.image.jpg?crop=1175%2C1175%2C294%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/a/d8/ad8bdc86-56ba-5185-8034-369749f41e05/605ce4c71889f.image.jpg?crop=1175%2C1175%2C294%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/a/d8/ad8bdc86-56ba-5185-8034-369749f41e05/605ce4c71889f.image.jpg?crop=1175%2C1175%2C294%2C0&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/a/d8/ad8bdc86-56ba-5185-8034-369749f41e05/605ce4c71889f.image.jpg?crop=1175%2C1175%2C294%2C0&resize=640%2C640&order=crop%2Cresize 640w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/a/d8/ad8bdc86-56ba-5185-8034-369749f41e05/605ce4c71889f.image.jpg?crop=1175%2C1175%2C294%2C0&resize=750%2C750&order=crop%2Cresize 750w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/a/d8/ad8bdc86-56ba-5185-8034-369749f41e05/605ce4c71889f.image.jpg?crop=1175%2C1175%2C294%2C0&resize=990%2C990&order=crop%2Cresize 990w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/a/d8/ad8bdc86-56ba-5185-8034-369749f41e05/605ce4c71889f.image.jpg?crop=1175%2C1175%2C294%2C0&resize=1035%2C1035&order=crop%2Cresize 1035w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/a/d8/ad8bdc86-56ba-5185-8034-369749f41e05/605ce4c71889f.image.jpg?crop=1175%2C1175%2C294%2C0&resize=1175%2C1175&order=crop%2Cresize 1200w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/ap_news/sports/shackelford-alabama-roll-past-maryland-and-into-sweet-16/image_e3146194-fa6e-5aa6-b97e-89325cd9d410.html" class="tnt-asset-link" >                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Shackelford, Alabama roll past Maryland and into Sweet 16"
                            class="img-responsive lazyload ap-photo full default"
                            width="1175"
                            height="1175"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/e/31/e3146194-fa6e-5aa6-b97e-89325cd9d410/60595de9126e8.image.jpg?crop=1175%2C1175%2C294%2C0&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/e/31/e3146194-fa6e-5aa6-b97e-89325cd9d410/60595de9126e8.image.jpg?crop=1175%2C1175%2C294%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/e/31/e3146194-fa6e-5aa6-b97e-89325cd9d410/60595de9126e8.image.jpg?crop=1175%2C1175%2C294%2C0&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/e/31/e3146194-fa6e-5aa6-b97e-89325cd9d410/60595de9126e8.image.jpg?crop=1175%2C1175%2C294%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/e/31/e3146194-fa6e-5aa6-b97e-89325cd9d410/60595de9126e8.image.jpg?crop=1175%2C1175%2C294%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/e/31/e3146194-fa6e-5aa6-b97e-89325cd9d410/60595de9126e8.image.jpg?crop=1175%2C1175%2C294%2C0&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/e/31/e3146194-fa6e-5aa6-b97e-89325cd9d410/60595de9126e8.image.jpg?crop=1175%2C1175%2C294%2C0&resize=640%2C640&order=crop%2Cresize 640w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/e/31/e3146194-fa6e-5aa6-b97e-89325cd9d410/60595de9126e8.image.jpg?crop=1175%2C1175%2C294%2C0&resize=750%2C750&order=crop%2Cresize 750w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/e/31/e3146194-fa6e-5aa6-b97e-89325cd9d410/60595de9126e8.image.jpg?crop=1175%2C1175%2C294%2C0&resize=990%2C990&order=crop%2Cresize 990w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/e/31/e3146194-fa6e-5aa6-b97e-89325cd9d410/60595de9126e8.image.jpg?crop=1175%2C1175%2C294%2C0&resize=1035%2C1035&order=crop%2Cresize 1035w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/e/31/e3146194-fa6e-5aa6-b97e-89325cd9d410/60595de9126e8.image.jpg?crop=1175%2C1175%2C294%2C0&resize=1175%2C1175&order=crop%2Cresize 1200w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/ap_news/sports/leading-off-nats-have-3-positives-no-opener-friday/image_7f27624a-41f0-57ba-ac99-0b090582a549.html" class="tnt-asset-link" >                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="LEADING OFF: Nats have 3 positives, no opener Friday"
                            class="img-responsive lazyload ap-photo full default"
                            width="1175"
                            height="1175"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/7/f2/7f27624a-41f0-57ba-ac99-0b090582a549/6052366480bdb.image.jpg?crop=1175%2C1175%2C294%2C0&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/7/f2/7f27624a-41f0-57ba-ac99-0b090582a549/6052366480bdb.image.jpg?crop=1175%2C1175%2C294%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/7/f2/7f27624a-41f0-57ba-ac99-0b090582a549/6052366480bdb.image.jpg?crop=1175%2C1175%2C294%2C0&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/7/f2/7f27624a-41f0-57ba-ac99-0b090582a549/6052366480bdb.image.jpg?crop=1175%2C1175%2C294%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/7/f2/7f27624a-41f0-57ba-ac99-0b090582a549/6052366480bdb.image.jpg?crop=1175%2C1175%2C294%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/7/f2/7f27624a-41f0-57ba-ac99-0b090582a549/6052366480bdb.image.jpg?crop=1175%2C1175%2C294%2C0&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/7/f2/7f27624a-41f0-57ba-ac99-0b090582a549/6052366480bdb.image.jpg?crop=1175%2C1175%2C294%2C0&resize=640%2C640&order=crop%2Cresize 640w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/7/f2/7f27624a-41f0-57ba-ac99-0b090582a549/6052366480bdb.image.jpg?crop=1175%2C1175%2C294%2C0&resize=750%2C750&order=crop%2Cresize 750w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/7/f2/7f27624a-41f0-57ba-ac99-0b090582a549/6052366480bdb.image.jpg?crop=1175%2C1175%2C294%2C0&resize=990%2C990&order=crop%2Cresize 990w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/7/f2/7f27624a-41f0-57ba-ac99-0b090582a549/6052366480bdb.image.jpg?crop=1175%2C1175%2C294%2C0&resize=1035%2C1035&order=crop%2Cresize 1035w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/7/f2/7f27624a-41f0-57ba-ac99-0b090582a549/6052366480bdb.image.jpg?crop=1175%2C1175%2C294%2C0&resize=1175%2C1175&order=crop%2Cresize 1200w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/ap_news/international/4-die-in-clashes-set-off-by-indias-modi-visiting-bangladesh/image_676ddc5b-9232-524f-bf32-5823c985bbb4.html" class="tnt-asset-link" >                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="4 die in clashes set off by India's Modi visiting Bangladesh"
                            class="img-responsive lazyload ap-photo full default"
                            width="1176"
                            height="1176"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/6/76/676ddc5b-9232-524f-bf32-5823c985bbb4/605dfb097c7bd.image.jpg?crop=1176%2C1176%2C293%2C0&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/6/76/676ddc5b-9232-524f-bf32-5823c985bbb4/605dfb097c7bd.image.jpg?crop=1176%2C1176%2C293%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/6/76/676ddc5b-9232-524f-bf32-5823c985bbb4/605dfb097c7bd.image.jpg?crop=1176%2C1176%2C293%2C0&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/6/76/676ddc5b-9232-524f-bf32-5823c985bbb4/605dfb097c7bd.image.jpg?crop=1176%2C1176%2C293%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/6/76/676ddc5b-9232-524f-bf32-5823c985bbb4/605dfb097c7bd.image.jpg?crop=1176%2C1176%2C293%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/6/76/676ddc5b-9232-524f-bf32-5823c985bbb4/605dfb097c7bd.image.jpg?crop=1176%2C1176%2C293%2C0&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/6/76/676ddc5b-9232-524f-bf32-5823c985bbb4/605dfb097c7bd.image.jpg?crop=1176%2C1176%2C293%2C0&resize=640%2C640&order=crop%2Cresize 640w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/6/76/676ddc5b-9232-524f-bf32-5823c985bbb4/605dfb097c7bd.image.jpg?crop=1176%2C1176%2C293%2C0&resize=750%2C750&order=crop%2Cresize 750w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/6/76/676ddc5b-9232-524f-bf32-5823c985bbb4/605dfb097c7bd.image.jpg?crop=1176%2C1176%2C293%2C0&resize=990%2C990&order=crop%2Cresize 990w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/6/76/676ddc5b-9232-524f-bf32-5823c985bbb4/605dfb097c7bd.image.jpg?crop=1176%2C1176%2C293%2C0&resize=1035%2C1035&order=crop%2Cresize 1035w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/6/76/676ddc5b-9232-524f-bf32-5823c985bbb4/605dfb097c7bd.image.jpg?crop=1176%2C1176%2C293%2C0&resize=1176%2C1176&order=crop%2Cresize 1200w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/ap_news/sports/infant-son-of-browns-switzer-stable-after-surgery-in-boston/image_f7107881-738f-5ee5-bed6-335efe7cc39e.html" class="tnt-asset-link" >                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Infant son of Browns' Switzer stable after surgery in Boston"
                            class="img-responsive lazyload ap-photo full default"
                            width="1199"
                            height="1199"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/f/71/f7107881-738f-5ee5-bed6-335efe7cc39e/605bc8cd6ed47.image.jpg?crop=1199%2C1199%2C265%2C0&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/f/71/f7107881-738f-5ee5-bed6-335efe7cc39e/605bc8cd6ed47.image.jpg?crop=1199%2C1199%2C265%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/f/71/f7107881-738f-5ee5-bed6-335efe7cc39e/605bc8cd6ed47.image.jpg?crop=1199%2C1199%2C265%2C0&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/f/71/f7107881-738f-5ee5-bed6-335efe7cc39e/605bc8cd6ed47.image.jpg?crop=1199%2C1199%2C265%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/f/71/f7107881-738f-5ee5-bed6-335efe7cc39e/605bc8cd6ed47.image.jpg?crop=1199%2C1199%2C265%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/f/71/f7107881-738f-5ee5-bed6-335efe7cc39e/605bc8cd6ed47.image.jpg?crop=1199%2C1199%2C265%2C0&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/f/71/f7107881-738f-5ee5-bed6-335efe7cc39e/605bc8cd6ed47.image.jpg?crop=1199%2C1199%2C265%2C0&resize=640%2C640&order=crop%2Cresize 640w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/f/71/f7107881-738f-5ee5-bed6-335efe7cc39e/605bc8cd6ed47.image.jpg?crop=1199%2C1199%2C265%2C0&resize=750%2C750&order=crop%2Cresize 750w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/f/71/f7107881-738f-5ee5-bed6-335efe7cc39e/605bc8cd6ed47.image.jpg?crop=1199%2C1199%2C265%2C0&resize=990%2C990&order=crop%2Cresize 990w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/f/71/f7107881-738f-5ee5-bed6-335efe7cc39e/605bc8cd6ed47.image.jpg?crop=1199%2C1199%2C265%2C0&resize=1035%2C1035&order=crop%2Cresize 1035w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/f/71/f7107881-738f-5ee5-bed6-335efe7cc39e/605bc8cd6ed47.image.jpg?crop=1199%2C1199%2C265%2C0&resize=1199%2C1199&order=crop%2Cresize 1200w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/ap_news/sports/clippers-hit-19-3s-beat-bucks-129-105-for-6th-win-in-a-row/image_7fc0c512-14bf-504a-bf08-8d519b289a6c.html" class="tnt-asset-link" >                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Clippers hit 19 3s, beat Bucks 129-105 for 6th win in a row"
                            class="img-responsive lazyload ap-photo full default"
                            width="1080"
                            height="1080"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/7/fc/7fc0c512-14bf-504a-bf08-8d519b289a6c/6062a9ed023f8.image.jpg?crop=1080%2C1080%2C420%2C0&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/7/fc/7fc0c512-14bf-504a-bf08-8d519b289a6c/6062a9ed023f8.image.jpg?crop=1080%2C1080%2C420%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/7/fc/7fc0c512-14bf-504a-bf08-8d519b289a6c/6062a9ed023f8.image.jpg?crop=1080%2C1080%2C420%2C0&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/7/fc/7fc0c512-14bf-504a-bf08-8d519b289a6c/6062a9ed023f8.image.jpg?crop=1080%2C1080%2C420%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/7/fc/7fc0c512-14bf-504a-bf08-8d519b289a6c/6062a9ed023f8.image.jpg?crop=1080%2C1080%2C420%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/7/fc/7fc0c512-14bf-504a-bf08-8d519b289a6c/6062a9ed023f8.image.jpg?crop=1080%2C1080%2C420%2C0&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/7/fc/7fc0c512-14bf-504a-bf08-8d519b289a6c/6062a9ed023f8.image.jpg?crop=1080%2C1080%2C420%2C0&resize=640%2C640&order=crop%2Cresize 640w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/7/fc/7fc0c512-14bf-504a-bf08-8d519b289a6c/6062a9ed023f8.image.jpg?crop=1080%2C1080%2C420%2C0&resize=750%2C750&order=crop%2Cresize 750w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/7/fc/7fc0c512-14bf-504a-bf08-8d519b289a6c/6062a9ed023f8.image.jpg?crop=1080%2C1080%2C420%2C0&resize=990%2C990&order=crop%2Cresize 990w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/7/fc/7fc0c512-14bf-504a-bf08-8d519b289a6c/6062a9ed023f8.image.jpg?crop=1080%2C1080%2C420%2C0&resize=1035%2C1035&order=crop%2Cresize 1035w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/7/fc/7fc0c512-14bf-504a-bf08-8d519b289a6c/6062a9ed023f8.image.jpg?crop=1080%2C1080%2C420%2C0&resize=1080%2C1080&order=crop%2Cresize 1200w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/ap_news/sports/stanford-rallies-to-beat-louisville-78-63-reach-final-four/image_37abde48-2e55-5813-a2d7-e90f094a80c2.html" class="tnt-asset-link" >                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Stanford rallies to beat Louisville 78-63, reach Final Four"
                            class="img-responsive lazyload ap-photo full default"
                            width="1176"
                            height="1176"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/3/7a/37abde48-2e55-5813-a2d7-e90f094a80c2/6063e97be7114.image.jpg?crop=1176%2C1176%2C293%2C0&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/3/7a/37abde48-2e55-5813-a2d7-e90f094a80c2/6063e97be7114.image.jpg?crop=1176%2C1176%2C293%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/3/7a/37abde48-2e55-5813-a2d7-e90f094a80c2/6063e97be7114.image.jpg?crop=1176%2C1176%2C293%2C0&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/3/7a/37abde48-2e55-5813-a2d7-e90f094a80c2/6063e97be7114.image.jpg?crop=1176%2C1176%2C293%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/3/7a/37abde48-2e55-5813-a2d7-e90f094a80c2/6063e97be7114.image.jpg?crop=1176%2C1176%2C293%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/3/7a/37abde48-2e55-5813-a2d7-e90f094a80c2/6063e97be7114.image.jpg?crop=1176%2C1176%2C293%2C0&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/3/7a/37abde48-2e55-5813-a2d7-e90f094a80c2/6063e97be7114.image.jpg?crop=1176%2C1176%2C293%2C0&resize=640%2C640&order=crop%2Cresize 640w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/3/7a/37abde48-2e55-5813-a2d7-e90f094a80c2/6063e97be7114.image.jpg?crop=1176%2C1176%2C293%2C0&resize=750%2C750&order=crop%2Cresize 750w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/3/7a/37abde48-2e55-5813-a2d7-e90f094a80c2/6063e97be7114.image.jpg?crop=1176%2C1176%2C293%2C0&resize=990%2C990&order=crop%2Cresize 990w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/3/7a/37abde48-2e55-5813-a2d7-e90f094a80c2/6063e97be7114.image.jpg?crop=1176%2C1176%2C293%2C0&resize=1035%2C1035&order=crop%2Cresize 1035w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/3/7a/37abde48-2e55-5813-a2d7-e90f094a80c2/6063e97be7114.image.jpg?crop=1176%2C1176%2C293%2C0&resize=1176%2C1176&order=crop%2Cresize 1200w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/ap_news/international/who-europes-vaccination-program-is-unacceptably-slow/image_a9f4f2d3-099f-541c-8cac-0bafe720486c.html" class="tnt-asset-link" >                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="WHO: Europe's vaccination program is 'unacceptably slow'"
                            class="img-responsive lazyload ap-photo full default"
                            width="1175"
                            height="1175"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/a/9f/a9f4f2d3-099f-541c-8cac-0bafe720486c/6065e04765e5b.image.jpg?crop=1175%2C1175%2C294%2C0&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/a/9f/a9f4f2d3-099f-541c-8cac-0bafe720486c/6065e04765e5b.image.jpg?crop=1175%2C1175%2C294%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/a/9f/a9f4f2d3-099f-541c-8cac-0bafe720486c/6065e04765e5b.image.jpg?crop=1175%2C1175%2C294%2C0&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/a/9f/a9f4f2d3-099f-541c-8cac-0bafe720486c/6065e04765e5b.image.jpg?crop=1175%2C1175%2C294%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/a/9f/a9f4f2d3-099f-541c-8cac-0bafe720486c/6065e04765e5b.image.jpg?crop=1175%2C1175%2C294%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/a/9f/a9f4f2d3-099f-541c-8cac-0bafe720486c/6065e04765e5b.image.jpg?crop=1175%2C1175%2C294%2C0&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/a/9f/a9f4f2d3-099f-541c-8cac-0bafe720486c/6065e04765e5b.image.jpg?crop=1175%2C1175%2C294%2C0&resize=640%2C640&order=crop%2Cresize 640w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/a/9f/a9f4f2d3-099f-541c-8cac-0bafe720486c/6065e04765e5b.image.jpg?crop=1175%2C1175%2C294%2C0&resize=750%2C750&order=crop%2Cresize 750w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/a/9f/a9f4f2d3-099f-541c-8cac-0bafe720486c/6065e04765e5b.image.jpg?crop=1175%2C1175%2C294%2C0&resize=990%2C990&order=crop%2Cresize 990w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/a/9f/a9f4f2d3-099f-541c-8cac-0bafe720486c/6065e04765e5b.image.jpg?crop=1175%2C1175%2C294%2C0&resize=1035%2C1035&order=crop%2Cresize 1035w, https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/assets/v3/editorial/a/9f/a9f4f2d3-099f-541c-8cac-0bafe720486c/6065e04765e5b.image.jpg?crop=1175%2C1175%2C294%2C0&resize=1175%2C1175&order=crop%2Cresize 1200w" />
                </a>
                
            </div>
            
        </figure></li>
                        </ul></div>
        
        <div id="videos-1266564" class="tab-pane tab-pane-videos fade in ">
                <h4 class="tab-content-heading">Videos</h4><p class="no-results text-muted">Sorry, there are no recent results for popular videos.</p></div>
        
        
        
        
    </div>
</div></section></div><div id="tncms-block-1266451" class="tncms-block hide"></div><div id="tncms-block-1266482" class="tncms-block mb_custom_list quad-pad-bottom well hide"></div><div id="tncms-block-1266510" class="tncms-block"><section id="block-1266510" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1266510 ">
        <div class="block-title-inner">
            <h4>
                
                Local Resource Links
                
            </h4>
        </div>
    </div></div><div id="html-asset-1266510">
            <div class="html-content">
<p>• <a href="http://www.co.kittitas.wa.us/" target="_&quot;blank&quot;">Kittitas County</a><br>
• <a href="http://www.ci.ellensburg.wa.us/" target="_&quot;blank&quot;">City of Ellensburg</a><br>
• <a href="http://www.cityofcleelum.com/" target="_&quot;blank&quot;">City of Cle Elum</a><br>
• <a href="http://www.ci.roslyn.wa.us/" target="_&quot;blank&quot;">City of Roslyn</a><br>
• <a href="http://www.cityofkittitas.com/" target="_&quot;blank&quot;">City of Kittitas</a><br>
• <a href="http://www.kittitascountychamber.com/" target="_&quot;blank&quot;">Kittitas County Chamber of Commercer</a><br>
• <a href="http://www.yakimatransit.org/" target="_&quot;blank&quot;">Yakima Transit</a><br>
• <a href="http://www.cleelumroslyn.org/" target="_&quot;blank&quot;">Cle Elum Roslyn Chamber of Commerce<br></a> • <a href="http://ellensburgrodeo.com/" target="_&quot;blank&quot;">Ellensburg Rodeo</a><br>
• <a href="https://www.myellensburg.com/" target="_&quot;blank&quot;">Visit My Ellensburg</a><br>
• <a href="http://www.visitkittitas.com/" target="_&quot;blank&quot;">Visit Kittitas County</a><br>
• <a href="http://access.wa.gov/" target="_&quot;blank&quot;">State of Washington</a><br>
• <a href="http://www.leg.wa.gov/pages/home.aspx" target="_&quot;blank&quot;">Washington Legislature</a><br>
• <a href="http://goo.gl/lHKRN" target="_&quot;blank&quot;">Daily Record Facebook</a><br>
• <a href="http://goo.gl/6QzH7" target="_&quot;blank&quot;">Daily Record Twitter</a></p>
</div>
        </div></section></div><div id="tncms-block-1276022" class="tncms-block hidden-sm hidden-xs"><div class="tnt-ads-container text-center "><div style="min-height:600px; min-width:300px;" class="tnt-ads dfp-ad" data-dfp-adunit="/94837440/ellensburg/drn/opinion/nation_of_mike" data-dfp-custom-pos="png_bottom" id="ad-1276022" data-dfp-size="[300, 600]" data-lazy="true"></div></div>
    
</div></div><div id="tncms-region-asset_side_bottom" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-tertiary" class="tncms-region "><div id="tncms-block-1514802" class="tncms-block"><div id="ap_widget_container_f33b70d0f32192bb01eda6ffaa5eeebb"></div>
<script src="https://digitalservices.ap.org/widget-content/f33b70d0f32192bb01eda6ffaa5eeebb"></script></div><div id="tncms-block-1514804" class="tncms-block"><div id="ap_widget_container_44ce9c4e98a18cf2df5b4b0b74ecb198"></div>
<script src="https://digitalservices.ap.org/widget-content/44ce9c4e98a18cf2df5b4b0b74ecb198"></script></div></div><div id="tncms-region-article_side_bottom" class="tncms-region hidden-print"></div>
                <div id="sticky-right-rail-spacer">
                    <div id="sticky-right-rail"><div id="tncms-region-global-side-sticky" class="tncms-region hidden-print"></div><div id="tncms-region-asset_side_sticky" class="tncms-region hidden-print"></div></div>
                </div>
                </div>
            </div></div>
</article>
<div class="row">
            <div class="col-md-12"><div id="tncms-region-global-container-bottom" class="tncms-region "><div id="tncms-block-1276026" class="tncms-block hidden-sm hidden-xs"><div class="tnt-ads-container text-center "><div style="min-height:90px; min-width:728px;" class="tnt-ads dfp-ad" data-dfp-adunit="/94837440/ellensburg/drn/opinion/nation_of_mike" data-dfp-custom-pos="png_bottom" id="ad-1276026" data-dfp-size="[728, 90]" data-lazy="true"></div></div>
    
</div><div id="tncms-block-1276028" class="tncms-block hidden-lg hidden-md"><div class="tnt-ads-container text-center "><div style="min-height:50px; min-width:320px;" class="tnt-ads dfp-ad" data-dfp-adunit="/94837440/ellensburg/drn/opinion/nation_of_mike" data-dfp-custom-pos="png_bottom" id="ad-1276028" data-dfp-size="[320,50]" data-lazy="true"></div></div>
    
</div></div></div>
        </div></section>
    <section id="main-bottom-container" class="container-fullscreen-region container-fluid">
        <div class="fullscreen-region"><div id="tncms-region-global-container-bottom-fullscreen" class="tncms-region "></div></div>
    </section><!-- / main-body-container -->
    </div>
    <div id="site-footer-container" class="hidden-print">
         
            <div class="container">
                <div id="asset-container-bottom" class="col-md-12">
                    <div id="tncms-region-asset_container_bottom" class="tncms-region hidden-print"></div> 
                </div>
            </div>
        

        
            <footer id="site-footer" class="container well-main">
                
                <div id="tncms-region-footer-top-col-full" class="tncms-region "></div>
                <div class="row">
                    <div id="footer-col-one" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-one" class="tncms-region "><div id="tncms-block-1266550" class="tncms-block"><section id="block-1266550" class="block emphasis-h4   " ><address>
    <strong>Daily Record</strong><br>
    401 N Main St<br>
    Ellensburg, WA 98926
    <br>
    
        <span class="fas tnt-phone" title="Phone"></span> 509-925-1414<br>
        <span class="fas tnt-envelope" title="Email address"></span> <a href="mailto:webmaster@kvnews.com">webmaster@kvnews.com</a><br>
    
</address></section></div></div></div>
    <div id="footer-col-two" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-two" class="tncms-region "></div><div id="tncms-region-nav-footer-col-two-nav" class="tncms-region-nav"><ul id="footer-col-two-nav_menu" class="bullet-nav nav-list" ><li>
                <a class="nav-link   tnt-section-about"  href="/site/about"  tabindex="0">
                    <span class="nav-label">About</span>
                </a></li><li>
                <a class="nav-link   tnt-section-privacy"  href="/site/privacy.html"  tabindex="0">
                    <span class="nav-label">Privacy</span>
                </a></li><li>
                <a class="nav-link   tnt-section-advertising"  href="https://issuu.com/dailyrecord/docs/rate_card_daily_record_2020"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Advertising</span>
                </a></li><li>
                <a class="nav-link   tnt-section-terms"  href="/site/terms.html"  tabindex="0">
                    <span class="nav-label">Terms</span>
                </a></li><li>
                <a class="nav-link   tnt-section-submit"  href="/site/forms/submit/"  tabindex="0">
                    <span class="nav-label">Submit</span>
                </a></li><li>
                <a class="nav-link   tnt-section-submission-forms"  href="/submissions/"  tabindex="0">
                    <span class="nav-label">Submission Forms</span>
                </a></li><li>
                <a class="nav-link   tnt-section-magazines"  href="https://issuu.com/dailyrecord/"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Magazines</span>
                </a></li></ul></div></div>
    <div id="footer-col-three" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-three" class="tncms-region "></div><div id="tncms-region-nav-footer-col-three-nav" class="tncms-region-nav"><ul id="footer-col-three-nav_menu" class="bullet-nav nav-list" ><li>
                <a class="nav-link   tnt-section-call-us-at-509-925-1414"  href="tel:5099251414"  tabindex="0">
                    <span class="nav-label">Call us at 509-925-1414</span>
                </a></li><li>
                <a class="nav-link   tnt-section-or-send-us-an-email"  href="mailto:webmaster@kvnews.com"  tabindex="0">
                    <span class="nav-label">or send us an email.</span>
                </a></li><li>
                <a class="nav-link   tnt-section-subscribe-today"  href="/subscribe/"  tabindex="0">
                    <span class="nav-label">Subscribe Today!</span>
                </a></li><li>
                <a class="nav-link   tnt-section-manage-your-subscription"  href="/managesubscription"  tabindex="0">
                    <span class="nav-label">Manage your subscription</span>
                </a></li><li>
                <a class="nav-link   tnt-section-pay-subscription-bill"  href="/managesubscription"  tabindex="0">
                    <span class="nav-label">Pay subscription bill</span>
                </a></li><li>
                <a class="nav-link   tnt-section-vacation-stop"  href="/managesubscription"  tabindex="0">
                    <span class="nav-label">Vacation stop</span>
                </a></li><li>
                <a class="nav-link   tnt-section-sign-up-for-our-daily-eblast-breaking-news-alerts"  href="/newsletter/signup/"  tabindex="0">
                    <span class="nav-label">Sign up for our daily eBlast & breaking news alerts</span>
                </a></li></ul></div></div>
                </div>
                <div id="tncms-region-footer-bottom-col-full" class="tncms-region "><div id="tncms-block-1266535" class="tncms-block margin-bottom-10"><div id="bdc-site-submissions" style="margin-top: 2em;">
    <div class="block-title">
        <div class="block-title-inner">
            <h4>Get in touch with the Daily Record</h4>
        </div>
    </div>
    <div class="row">
      <div class="col-md-4 span4">
        <h5>Common Submissions</h5>
        <ul class="nav nav-pills nav-stacked">
          <li><a href="/site/forms/submit/news">Submit News</a></li>
          <li><a href="/site/forms/submit/sports">Submit Sports Tips</a></li>
          <li><a href="/site/forms/submit/letters">Letter to the Editor</a></li>
          <li><a href="http://selfserve.dailyrecordnews.com/dailyrecord-adportal/obits/index.html">Submit an Obituary</a></li>
          <li><a href="https://portal.cityspark.com/EventEntry/EventEntry/EllensburgDailyRecord">Add a Calendar Event</a></li>
        </ul>
      </div>
      <div class="col-md-4 span4">
        <ul class="nav nav-pills nav-stacked">
          <li><a href="javascript:void(window.open('https://classadz.vdata.com/EllensburgDailyRecord/Advertising/Advertiser'));">Place a Classified Ad</a></li>
          <li><a href="http://kvnews.mycapture.com/mycapture/index.asp?">Buy photos</a></li>
        </ul>
        <h5>Subscribers</h5>
        <ul class="nav nav-pills nav-stacked">
          <li><a href="/subscriptions">Subscribe</a></li>
          <li><a href="/managesubscription">Manage your subscription</a></li>
          <li><a href="/managesubscription">Vacation Stop</a></li>
	  <li><a href="/site/faq/">FAQ's</a></li>
        </ul>
      </div>
      <div class="col-md-4 span4">
        <h5>Milestones Announcements</h5>
        <ul class="nav nav-pills nav-stacked">
          <li><a href="/site/forms/submit/engagement/">Engagements</a></li>
          <li><a href="/site/forms/submit/wedding/">Weddings</a></li>
          <li><a href="/site/forms/submit/anniversary">Anniversaries</a></li>
        </ul>
      </div>
    </div>
</div></div></div>
                

    

            </footer>
        

        <div id="site-copyright-container" class="container">
            <div id="tncms-region-footer-copyright" class="tncms-region "><div id="tncms-block-1266551" class="tncms-block"><div id="site-copyright" class="row">
    <section id="block-1266551"><div class="col-md-7"><small>&copy; Copyright 2021 <a href="/">The Daily Record</a>, 401 N Main St Ellensburg, WA</small><small>&nbsp;| <a href="/site/terms.html">Terms of Use</a></small><small>&nbsp;| <a href="/site/privacy.html">Privacy Policy</a></small></div>
        <div class="col-md-5"><small>Powered by <a href="https://bloxcms.com" title="BLOX Content Management System" target="_blank" rel="noopener">BLOX Content Management System</a> from <a href="https://townnews.com/" title="TownNews.com BLOX Newspaper Content Management" target="_blank" rel="noopener">TownNews.com</a>.</small></div>
    </section>
</div></div><div id="tncms-block-1489597" class="tncms-block"><div id="drn-footer-spacer" style="height:60px;width:100%;clear:both;"> </div>
<style>
.eburgfooter {
  z-index:10;
}
</style></div></div>
        </div>
    </div>
    
    
        </div><!-- / offcanvas close  -->
    

    
    
    <!-- / site-container close -->
    </div>
    
    
    <script>
        window.__tnt = window.__tnt || {};
        __tnt.compatibility = __tnt.compatibility || {};

        __tnt.compatibility.status = '';
        __tnt.compatibility.check = function() {
            if (typeof __tnt.advertisements == 'undefined') {
                __tnt.compatibility.status = 'FAIL: object 0 undefined';
                return false;
            }
            return true;
        };
        __tnt.compatibility.notification = function() {
            if (!document.getElementById('notification-area')) {
                    var el = document.createElement('div');
                    el.id = 'notification-area';
                    document.querySelector('#asset-content .asset-body').appendChild(el);
                }
                __tnt.template(
                    document.getElementById('template-blox-message-incompatible'),
                    document.getElementById('notification-area'),
                    true,
                    [],
                    function(el) {
                        setTimeout(function() {
                            var message = document.getElementById('blox-message-incompatible');
                            var authStatusCls = (__tnt.user.authToken) ? 'logged-in' : 'not-logged-in';
                                Array.from(message.getElementsByClassName(authStatusCls)).forEach(function(el) {
                                    el.style.display = 'block';
                                });
                            
                            if (__tnt.user.services) {
                                message.parentNode.removeChild(message);
                            } else {
                                message.style.display = 'block';
                                }
                        }, 100);
                    }
                );
            };
        (function() {
            function compatibilityCheck() {
                if (!__tnt.compatibility.check()) {
                    __tnt.trackEvent({
                        'category':'subscription',
                        'action':'adblock',
                        'label':'adblock detected',
                        'value':'1'
                    });
                    __tnt.compatibility.notification();
                }
            }

            if (document.readyState != 'loading') {
                compatibilityCheck();
            } else {
                document.addEventListener('DOMContentLoaded', compatibilityCheck);
            }
        })();
    </script>
    <template id="template-blox-message-incompatible">
            </template>
    
    
    <script>
        jQuery(function() {
            if(typeof TNCMS.Tracking != 'undefined'){
                jQuery(TNCMS.Tracking.trackDeclarativeEvents);
            }dataLayer.push({'tncms.client.recent_five':__tnt.recentFive.add("a9acb7ce-fe24-5a01-a44c-001a8d276fbc")});});
    </script>

    <script>
        __tnt.trackEvent = function(obj) {
            if (typeof obj === 'object') {
                    if (obj.category && obj.action) {
                        __tnt.googleEvent(obj);
                    } else if (obj.network && obj.socialAction) {
                        __tnt.googleSocial(obj);
                    } else if (obj.url) {
                        __tnt.googlePageView(obj);
                    }
                    if (typeof TNCMS.Tracking != 'undefined' && obj.metric) {
                        TNCMS.Tracking.addEvent({
                            app: obj.app,
                            metric: obj.metric,
                            id: obj.uuid
                        });
                    }
            }
        };

        if (__tnt.trackEventLater.length > 0) {
            __tnt.trackEventLater.forEach(function(obj) {
                __tnt.trackEvent(obj);
            });
        }

        Array.from(document.querySelectorAll('body [data-track]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.track));
            });
        });
        Array.from(document.querySelectorAll('body [data-tncms-track-event]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.tncmsTrackEvent));
            });
        });
        
        Array.from(document.querySelectorAll('body [data-tncms-track-dmp]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                var dmpData = el.dataset.tncmsTrackDmp;
                _cc9940.add('act', dmpData);_cc9940.bcp();
            });
        });
    
    </script>
    
    
<script src="https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/live/libraries/flex/components/site/resources/scripts/main.js?_dc=1522853914"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/live/libraries/flex/components/png_core/resources/scripts/png.js?_dc=1597129252"></script>
<script>/*<![CDATA[*/ 
                __tnt.googleEvent = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.trigger',
                             'tncms.event.trigger.category': obj.category,
                             'tncms.event.trigger.action': obj.action,
                             'tncms.event.trigger.label': obj.label, 
                             'tncms.event.trigger.value': obj.value
                    });
                }
                /* Virtual page view */
                __tnt.googlePageView = function(obj) {
                    var sURL = obj.url.replace(/^.*\/\/[^\/]+/, '');
                    dataLayer.push({
                        'event': 'tncms.event.virtual_pageview',
                            'tncms.event.virtual_pageview.url': sURL,
                            'tncms.event.virtual_pageview.title': obj.title
                    });
                }
                /* Social event */
                __tnt.googleSocial = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.social',
                            'tncms.event.social.network': obj.network,
                            'tncms.event.social.action': obj.socialAction,
                            'tncms.event.social.target': obj.url
                    });
                } /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/shared-content/art/tncms/templates/libraries/flex/components/metering/resources/scripts/tnt.metering.c1fd4b9015c14b57a58acdbc3ee4daca.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/asset-edit.60e8e67e04be1194326dcfbe7f00b8c3.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/scripts/promo_popup.fe40d77fce691e6ed54cb520a782a693.js"></script>
<script>/*<![CDATA[*/ 
            // Observer callback
            var callback = function(entries, io) {
                entries.forEach(function(e) {
                    if (e.isIntersecting === true) {
                        __tnt.template(
                            document.querySelector('#' + e.target.id + ' template'),
                            document.getElementById(e.target.id),
                            false,
                            objectFitImages('#' + e.target.id + ' img') // IE11 objectfit polyfill
                        );
                        // Kill observer
                        io.unobserve(e.target);
                    }
                });
            };
            // Initialize observer
            window.addEventListener('load', function() {
                var io = new IntersectionObserver(callback),
                    targets = Array.from(document.querySelectorAll('[data-lazy-content]')); // IE11 forEach support
                targets.forEach(function(e){
                    io.observe(e);
                });
            }, false) /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/live/libraries/flex/components/png_core/resources/scripts/jquery.fancybox.pack.js?_dc=1597129252"></script>
<script>/*<![CDATA[*/ 
            jQuery(document).ready(function($){
                var iqLogin = Cookies.get('tnt-iq-login') || false;
                if (__tnt.user.loggedIn && iqLogin == false) {
                    if (__tnt.user.services) {
                        var userServices = __tnt.user.services.split(',');
                        for (i = 0; i < userServices.length; i++) { 
                            var serviceData = 'has_subservice: ' + userServices[i];
                            _cc9940.add('act', serviceData);_cc9940.bcp();
                        }
                    }
                    Cookies.set('tnt-iq-login', 1);
                }
            });
        
            if (window.location.hash){
                var hashSet = ['tncms_source','utm_source','utm_campaign','utm_medium','utm_content','utm_term'],
                    urlHash = window.location.hash.replace('#','').split('&');
                for (var i = 0; i < urlHash.length; i++) {
                    var data = urlHash[i].split('='),
                        param = data[0].replace('-','_');
                    if (hashSet.indexOf(param) != -1){
                        var dmpData = param + ': ' + data[1];
                        _cc9940.add('act', dmpData);_cc9940.bcp();
                    }
                }
            }
         /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/dailyrecordnews.com/content/tncms/live/libraries/flex/components/ads_dfp/resources/scripts/dfp.lazy.min.js?_dc=1604390452"></script></body>
</html>